summaryrefslogtreecommitdiffstats
path: root/libvncserver/Makefile.am
diff options
context:
space:
mode:
authorGernot Tenchio <gernot.tenchio@securepoint.de>2011-08-17 12:20:50 +0200
committerJohannes Schindelin <johannes.schindelin@gmx.de>2011-08-17 12:41:24 +0200
commita2a6e256998c23af2d91a4475aa6d65893bf5bb5 (patch)
tree822a2debaa452150df01563523075ea447a7e797 /libvncserver/Makefile.am
parent4aa35863676335917d2a25a7952031f0fba66dfb (diff)
downloadlibtdevnc-a2a6e256998c23af2d91a4475aa6d65893bf5bb5.tar.gz
libtdevnc-a2a6e256998c23af2d91a4475aa6d65893bf5bb5.zip
websockets: add GnuTLS and OpenSSL support
For now, only OpenSSL support is activated through configure, since GnuTLS is only used in LibVNCClient. [jes: separated this out from the commit adding encryption support, added autoconf support.] Signed-off-by: Johannes Schindelin <johannes.schindelin@gmx.de>
Diffstat (limited to 'libvncserver/Makefile.am')
-rw-r--r--libvncserver/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/libvncserver/Makefile.am b/libvncserver/Makefile.am
index bbc8feb..c1f89df 100644
--- a/libvncserver/Makefile.am
+++ b/libvncserver/Makefile.am
@@ -13,7 +13,18 @@ TIGHTVNCFILETRANSFERSRCS = tightvnc-filetransfer/rfbtightserver.c \
endif
if WITH_WEBSOCKETS
-WEBSOCKETSSRCS = websockets.c md5.c rfbssl_none.c
+
+if HAVE_LIBSSL
+WEBSOCKETSSSLSRCS = rfbssl_openssl.c
+else
+#if HAVE_GNUTLS
+#WEBSOCKETSSSLSRCS = rfbssl_gnutls.c
+#else
+WEBSOCKETSSSLSRCS = rfbssl_none.c
+#endif
+endif
+
+WEBSOCKETSSRCS = websockets.c md5.c $(WEBSOCKETSSSLSRCS)
endif
includedir=$(prefix)/include/rfb