summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-08-01 10:58:00 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-08-01 10:58:00 +0200
commit8b7f762e49180a4776224d4118ac44aebe1aadc5 (patch)
tree7f5865ef6f14cfc5a6e6739747faae2e09134deb /CMakeLists.txt
parent45b09e0683e79bd5ef39a02b9fa184f2468523b4 (diff)
downloadmathemagics-8b7f762e49180a4776224d4118ac44aebe1aadc5.tar.gz
mathemagics-8b7f762e49180a4776224d4118ac44aebe1aadc5.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f092297..dd3eda5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,8 +67,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### source directories
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files