summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-08-01 10:58:00 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-08-01 10:58:12 +0200
commitd74d1b2542446e1e051cc5e951c4113d13115d71 (patch)
treef0840e5b485d16e7fa89e382544aa0e9300c397f /doc/CMakeLists.txt
parenta7beba33469458c564aa0eab3d3e0c2a088e7faa (diff)
downloadmathemagics-d74d1b2542446e1e051cc5e951c4113d13115d71.tar.gz
mathemagics-d74d1b2542446e1e051cc5e951c4113d13115d71.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 8b7f762e49180a4776224d4118ac44aebe1aadc5)
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt34
1 files changed, 0 insertions, 34 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
deleted file mode 100644
index f6eec15..0000000
--- a/doc/CMakeLists.txt
+++ /dev/null
@@ -1,34 +0,0 @@
-file( GLOB _dirs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} * )
-list( REMOVE_ITEM _dirs html man )
-
-string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
-
-foreach( _dir IN LISTS _dirs )
- if( IS_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/${_dir}
- AND ( "${_dir}" STREQUAL "en" OR
- "${_linguas}" MATCHES "^;*$" OR
- ";${_linguas};" MATCHES ";${_dir};" ))
- file( GLOB _doc_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}/${_dir} ${_dir}/*.docbook )
- if( _doc_files )
- list( FIND _doc_files "index.docbook" _find_index )
- if( -1 EQUAL _find_index )
- set( _noindex "NOINDEX" )
- else()
- unset( _noindex )
- endif()
- tde_create_handbook(
- SOURCE_BASEDIR ${_dir}
- ${_noindex}
- LANG ${_dir}
- DESTINATION ${PROJECT_NAME}
- )
- endif()
- endif()
-endforeach()
-
-if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/html/CMakeLists.txt )
- add_subdirectory( html )
-endif()
-if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/man/CMakeLists.txt )
- add_subdirectory( man )
-endif()