summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..a0c7233
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,10 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+SUBDIRS = common xml_to_data devices piklab-hex coff piklab-coff progs piklab-prog tools data libgui piklab piklab-test
+
+messages:
+ $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc` > rc.cpp
+ LIST=`find . -name \*.h -o -name \*.cpp -o -name \*.c`; \
+ if test -n "$$LIST"; then \
+ $(XGETTEXT) $$LIST --from-code=UTF-8 -o $(podir)/piklab.pot; \
+ fi