summaryrefslogtreecommitdiffstats
path: root/src/devices/mem24/xml_data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/devices/mem24/xml_data/Makefile.am')
-rw-r--r--src/devices/mem24/xml_data/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/devices/mem24/xml_data/Makefile.am b/src/devices/mem24/xml_data/Makefile.am
new file mode 100644
index 0000000..42cacaa
--- /dev/null
+++ b/src/devices/mem24/xml_data/Makefile.am
@@ -0,0 +1,12 @@
+INCLUDES = -I$(top_srcdir)/src $(all_includes)
+METASOURCES = AUTO
+
+noinst_LTLIBRARIES = libmem24xml.la
+libmem24xml_la_LDFLAGS = $(all_libraries)
+libmem24xml_la_SOURCES = mem24_data.cpp
+libmem24xml_la_DEPENDENCIES = mem24_data.cpp
+
+include deps.mak
+mem24_data.cpp: ../xml/mem24_xml_to_data $(noinst_DATA)
+ ../xml/mem24_xml_to_data
+CLEANFILES = mem24_data.cpp