summaryrefslogtreecommitdiffstats
path: root/src/devices/pic/xml_data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/devices/pic/xml_data/Makefile.am')
-rw-r--r--src/devices/pic/xml_data/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/devices/pic/xml_data/Makefile.am b/src/devices/pic/xml_data/Makefile.am
new file mode 100644
index 0000000..43b13d4
--- /dev/null
+++ b/src/devices/pic/xml_data/Makefile.am
@@ -0,0 +1,12 @@
+INCLUDES = -I$(top_srcdir)/src $(all_includes)
+METASOURCES = AUTO
+
+noinst_LTLIBRARIES = libpicxml.la
+libpicxml_la_SOURCES = pic_data.cpp
+libpicxml_la_DEPENDENCIES = pic_data.cpp
+
+include deps.mak
+noinst_DATA += registers/registers.xml registers/registers_missing.xml
+pic_data.cpp: ../xml/pic_xml_to_data $(noinst_DATA)
+ ../xml/pic_xml_to_data
+CLEANFILES = pic_data.cpp