summaryrefslogtreecommitdiffstats
path: root/src/tools/boost/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/boost/CMakeLists.txt')
-rw-r--r--src/tools/boost/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/tools/boost/CMakeLists.txt b/src/tools/boost/CMakeLists.txt
new file mode 100644
index 0000000..8841e0b
--- /dev/null
+++ b/src/tools/boost/CMakeLists.txt
@@ -0,0 +1,17 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
+
+
+##### subfolders
+
+add_subdirectory( gui )
+
+
+##### libboost (static)
+
+tde_add_library( boost STATIC_PIC AUTOMOC
+ SOURCES
+ boostc.cpp boostc_compile.cpp boost_config.cpp
+ boost.cpp boostcpp.cpp boostbasic.cpp boost_generator.cpp
+)