summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2021-11-16 00:33:12 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2021-11-16 00:33:12 +0900
commita8e9f8dd80bddc39a64cd807880b5630fb9efec7 (patch)
tree866a00fc55bdfada1dd3d46c61feb1440d960526 /CMakeLists.txt
parent98b37ff3b1d307add5fe3f9e1f9c7923831debd4 (diff)
downloadpolkit-tqt-a8e9f8dd80bddc39a64cd807880b5630fb9efec7.tar.gz
polkit-tqt-a8e9f8dd80bddc39a64cd807880b5630fb9efec7.zip
Conversion of 'agent' library module.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 8 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8470dfeb1..fb52aa96c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -111,17 +111,19 @@ install(
install(
FILES
+ includes/PolkitTQt/Agent/Listener
+ includes/PolkitTQt/Agent/Session
+ DESTINATION
+ ${INCLUDE_INSTALL_DIR}/PolkitTQt/Agent
+)
+
+install(
+ FILES
polkit-tqt-export.h
-## agent/polkittqt1-agent-listener.h
-## agent/polkittqt1-agent-session.h
-##
## ${CMAKE_CURRENT_BINARY_DIR}/polkittqt1-version.h
-##
DESTINATION
${INCLUDE_INSTALL_DIR} )
-## find_package(GObject REQUIRED)
-## find_package(GIO REQUIRED)
##
## include (${TQT_USE_FILE})
## include (InstallSettings)
@@ -162,11 +164,6 @@ install(
## DESTINATION
## ${INCLUDE_INSTALL_DIR}/polkit-qt-1 )
##
-## install(FILES
-## includes/PolkitTQt/Agent/Listener
-## includes/PolkitTQt/Agent/Session
-## DESTINATION
-## ${INCLUDE_INSTALL_DIR}/polkit-qt-1/PolkitTQt/Agent )
##
## # CMake Config files
## configure_file(PolkitTQt-1Config.cmake.in "${CMAKE_BINARY_DIR}/PolkitTQt-1Config.cmake" @ONLY)