summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt27
1 files changed, 10 insertions, 17 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index dc492af4d..896959b84 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -25,7 +25,12 @@ link_directories(
##### install headers ###########################
install( FILES
+ polkit-tqt-actiondescription.h
+ polkit-tqt-authority.h
+ polkit-tqt-details.h
+ polkit-tqt-identity.h
polkit-tqt-subject.h
+ polkit-tqt-temporaryauthorization.h
DESTINATION ${INCLUDE_INSTALL_DIR} )
@@ -33,31 +38,19 @@ install( FILES
tde_add_library( polkit-tqt-core SHARED AUTOMOC
SOURCES ${polkit_tqt_MOCS}
+ polkit-tqt-actiondescription.cpp
+ polkit-tqt-authority.cpp
+ polkit-tqt-details.cpp
+ polkit-tqt-identity.cpp
polkit-tqt-subject.cpp
+ polkit-tqt-temporaryauthorization.cpp
VERSION 0.0.0
LINK ${TQT_LIBRARIES} ${POLKIT_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}
)
-## set(polkit_tqt_core_SRCS
-## polkittqt1-authority.cpp
-## polkittqt1-identity.cpp
-## polkittqt1-temporaryauthorization.cpp
-## polkittqt1-details.cpp
-## polkittqt1-actiondescription.cpp
-## )
-##
-## target_link_libraries(polkit-tqt-core-1
-## ${TQT_TQTDBUS_LIBRARY}
-## ${TQT_TQTXML_LIBRARY}
-## ${GLIB2_LIBRARIES}
-## ${GOBJECT_LIBRARIES}
-## ${GIO_LIBRARIES}
-## )
##
## set_target_properties(polkit-tqt-core-1 PROPERTIES VERSION ${POLKITTQT-1_LIBRARY_VERSION}
## SOVERSION ${POLKITTQT-1_ABI_VERSION}
## DEFINE_SYMBOL MAKE_POLKITTQT1_LIB)
-##
-## install(TARGETS polkit-tqt-core-1 ${INSTALL_TARGETS_DEFAULT_ARGS})