summaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt53
1 files changed, 26 insertions, 27 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index ed7519be0..dc492af4d 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -10,9 +10,11 @@
#################################################
include_directories(
+ ${CMAKE_SOURCE_DIR}
${CMAKE_CURRENT_BINARY_DIR}
${CMAKE_CURRENT_SOURCE_DIR}
${TQT_INCLUDE_DIRS}
+ ${POLKIT_INCLUDE_DIRS}
)
link_directories(
@@ -23,7 +25,7 @@ link_directories(
##### install headers ###########################
install( FILES
- dummy-core.h
+ polkit-tqt-subject.h
DESTINATION ${INCLUDE_INSTALL_DIR} )
@@ -31,34 +33,31 @@ install( FILES
tde_add_library( polkit-tqt-core SHARED AUTOMOC
SOURCES ${polkit_tqt_MOCS}
- dummy-core.cpp
+ polkit-tqt-subject.cpp
VERSION 0.0.0
- LINK ${TQT_LIBRARIES}
+ LINK ${TQT_LIBRARIES} ${POLKIT_LIBRARIES}
DESTINATION ${LIB_INSTALL_DIR}
)
-## set(polkit_tqt_core_SRCS
-## polkittqt1-authority.cpp
-## polkittqt1-identity.cpp
-## polkittqt1-subject.cpp
-## polkittqt1-temporaryauthorization.cpp
-## polkittqt1-details.cpp
-## polkittqt1-actiondescription.cpp
-## )
-##
-## target_link_libraries(polkit-tqt-core-1
-## ${TQT_TQTCORE_LIBRARY}
-## ${TQT_TQTDBUS_LIBRARY}
-## ${TQT_TQTXML_LIBRARY}
-## ${POLKIT_LIBRARIES}
-## ${GLIB2_LIBRARIES}
-## ${GOBJECT_LIBRARIES}
-## ${GIO_LIBRARIES}
-## )
-##
-## set_target_properties(polkit-tqt-core-1 PROPERTIES VERSION ${POLKITTQT-1_LIBRARY_VERSION}
-## SOVERSION ${POLKITTQT-1_ABI_VERSION}
-## DEFINE_SYMBOL MAKE_POLKITTQT1_LIB)
-##
-## install(TARGETS polkit-tqt-core-1 ${INSTALL_TARGETS_DEFAULT_ARGS})
+## set(polkit_tqt_core_SRCS
+## polkittqt1-authority.cpp
+## polkittqt1-identity.cpp
+## polkittqt1-temporaryauthorization.cpp
+## polkittqt1-details.cpp
+## polkittqt1-actiondescription.cpp
+## )
+##
+## target_link_libraries(polkit-tqt-core-1
+## ${TQT_TQTDBUS_LIBRARY}
+## ${TQT_TQTXML_LIBRARY}
+## ${GLIB2_LIBRARIES}
+## ${GOBJECT_LIBRARIES}
+## ${GIO_LIBRARIES}
+## )
+##
+## set_target_properties(polkit-tqt-core-1 PROPERTIES VERSION ${POLKITTQT-1_LIBRARY_VERSION}
+## SOVERSION ${POLKITTQT-1_ABI_VERSION}
+## DEFINE_SYMBOL MAKE_POLKITTQT1_LIB)
+##
+## install(TARGETS polkit-tqt-core-1 ${INSTALL_TARGETS_DEFAULT_ARGS})