summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-21 01:00:15 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-21 01:00:33 +0200
commit1108ff8e5b25a81246bcea5b1b8087a16887e005 (patch)
tree5eb8262517ccf6f33420cf6aa8dc1929ea3e69a6 /CMakeLists.txt
parentcf2d8fbd8413bc1b73c0f007e7d2dd6c7afa777e (diff)
downloadpotracegui-1108ff8e5b25a81246bcea5b1b8087a16887e005.tar.gz
potracegui-1108ff8e5b25a81246bcea5b1b8087a16887e005.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 542c4844927089c9f9a9d376e51332d9d0d2d375)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 51d71d5..a5434e7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,8 +69,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files