summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-07-04 04:25:40 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-07-04 16:05:56 +0200
commitc1af0d24170f02f8c9d267258bdb7741426c9a39 (patch)
tree669aedd4856e8b9af2d36d202210122cfaf97df9 /CMakeLists.txt
parentbf76e158be9f0db60eb55bcb5395ebc76389dc3f (diff)
downloadsmartcardauth-c1af0d24170f02f8c9d267258bdb7741426c9a39.tar.gz
smartcardauth-c1af0d24170f02f8c9d267258bdb7741426c9a39.zip
Conversion to the cmake building system.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt121
1 files changed, 121 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..90b7812
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,121 @@
+############################################
+# #
+# Improvements and feedbacks are welcome #
+# #
+# This file is released under GPL >= 3 #
+# #
+############################################
+
+
+cmake_minimum_required( VERSION 2.8 )
+
+
+#### general package setup
+
+project( smartcardauth )
+set( VERSION R14.0.7 )
+
+
+#### include essential cmake modules
+
+include( FindPkgConfig )
+include( CheckFunctionExists )
+include( CheckSymbolExists )
+include( CheckIncludeFile )
+include( CheckLibraryExists )
+include( CheckCSourceCompiles )
+
+
+#### include our cmake modules
+
+set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
+include( TDEMacros )
+
+
+##### setup install paths
+
+include( TDESetupPaths )
+tde_setup_paths( )
+
+
+##### optional stuff
+
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+
+
+##### configure checks
+
+include( ConfigureChecks.cmake )
+
+
+###### global compiler settings
+
+add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST )
+
+set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
+set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined" )
+
+
+##### directories
+
+add_subdirectory( src )
+
+
+##### write configure files
+
+configure_file( config.h.cmake config.h @ONLY )
+
+
+##### scriptor_standalone (executable)
+
+file( READ scriptor_standalone.pl SCRIPTOR )
+string( REPLACE "scriptor" "scriptor_standalone" SCRIPTOR_STANDALONE "${SCRIPTOR}" )
+file( WRITE ${CMAKE_CURRENT_BINARY_DIR}/scriptor_standalone.pl "${SCRIPTOR_STANDALONE}" )
+
+add_custom_command( OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/scriptor_standalone
+ COMMAND ${PERL_PAR_PACKER}
+ -a ${PERL_LIB_CHIPCARD}
+ -o ${CMAKE_CURRENT_BINARY_DIR}/scriptor_standalone
+ ${CMAKE_CURRENT_BINARY_DIR}/scriptor_standalone.pl
+ COMMENT "Build scriptor_standalone"
+)
+
+add_custom_target( scriptor_standalone-binary ALL
+ DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/scriptor_standalone
+)
+
+install(
+ PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/scriptor_standalone
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ DIRECTORY etc/
+ DESTINATION ${SYSCONF_INSTALL_DIR}
+)
+
+file( GLOB SCRIPTS usr/bin/* )
+
+install(
+ PROGRAMS ${SCRIPTS}
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+file( GLOB INITRAMFS_HOOKS usr/share/initramfs-tools/hooks/* )
+
+install(
+ PROGRAMS ${INITRAMFS_HOOKS}
+ DESTINATION ${SHARE_INSTALL_PREFIX}/initramfs-tools/hooks
+)
+
+install(
+ DIRECTORY
+ usr/share/applications
+ usr/share/icons
+ DESTINATION ${SHARE_INSTALL_PREFIX}
+)