summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..ddfca88
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,21 @@
+if compile_konqplugin
+ PLUGINDIR=plugin
+endif
+
+EXTRA_DIST = admin AUTHORS COPYING ChangeLog INSTALL README TODO smb4k.lsm BUGS FAQ
+
+AUTOMAKE_OPTIONS = foreign 1.5
+
+MAINTAINERCLEANFILES = subdirs configure.in acinclude.m4 configure.files
+
+package-messages:
+ $(MAKE) -f admin/Makefile.common package-messages
+ $(MAKE) -C po merge
+
+#include admin/deps.am
+
+SUBDIRS = smb4k $(PLUGINDIR) utilities po doc
+
+messages: rc.cpp
+ $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc` > rc.cpp
+ $(XGETTEXT) `find . -name \*.cpp` -o $(podir)/smb4k.pot