summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 11:09:05 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 17:10:00 +0900
commitcac317d3ffb7b9838fb05b3b95b0542ca90a0b94 (patch)
tree657d0f8ed6cf89b0181640944164f3b806fc28a3 /CMakeLists.txt
parent74cbc6e1845961a81547e0fc6ea84bfa863959da (diff)
downloadtastymenu-cac317d3ffb7b9838fb05b3b95b0542ca90a0b94.tar.gz
tastymenu-cac317d3ffb7b9838fb05b3b95b0542ca90a0b94.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 077bb238afb42ab22e7a14b577a92f55a0f2482b)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c70a7eb..deedcfe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )