summaryrefslogtreecommitdiffstats
path: root/app-mobilephone/gsmlib
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-01-08 21:41:14 +0100
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-01-18 12:12:02 +0000
commit3de8a3c7c50cfcaf9334ee8a538998fd4763bcf5 (patch)
tree62fe2158c1557e681289051da5e33050cabb9534 /app-mobilephone/gsmlib
parent154a5b4a89084de1d9dfa2be4985dd3714d0b6e0 (diff)
downloadtde-packaging-gentoo-3de8a3c7c50cfcaf9334ee8a538998fd4763bcf5.tar.gz
tde-packaging-gentoo-3de8a3c7c50cfcaf9334ee8a538998fd4763bcf5.zip
App-mobilephone: Port to EAPI7 + cleanup.
Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'app-mobilephone/gsmlib')
-rw-r--r--app-mobilephone/gsmlib/gsmlib-1.11_pre041028.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/app-mobilephone/gsmlib/gsmlib-1.11_pre041028.ebuild b/app-mobilephone/gsmlib/gsmlib-1.11_pre041028.ebuild
index 2b9a496e..c8d3bd78 100644
--- a/app-mobilephone/gsmlib/gsmlib-1.11_pre041028.ebuild
+++ b/app-mobilephone/gsmlib/gsmlib-1.11_pre041028.ebuild
@@ -1,28 +1,32 @@
# Copyright 1999-2010 Gentoo Foundation
+# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI="7"
+
inherit eutils
DESCRIPTION="Library and applications to access GSM mobile phones"
SRC_URI="http://www.pxh.de/fs/gsmlib/snapshots/${PN}-pre${PV%_pre*}-${PV#*_pre}.tar.gz"
HOMEPAGE="http://www.pxh.de/fs/gsmlib/"
-IUSE=""
SLOT="0"
LICENSE="LGPL-2"
-KEYWORDS="amd64 ~ia64 ppc ppc64 sparc x86"
+KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
RESTRICT="test"
S="${WORKDIR}/${PN}-${PV%_pre*}"
+PATCHES=(
+ "${FILESDIR}/${P%_pre*}-include-gcc34-fix.patch"
+ "${FILESDIR}/${P%_pre*}-gcc41.patch"
+ "${FILESDIR}/${P%_pre*}-gcc43.patch"
+)
+
src_unpack() {
unpack ${A}
-
- epatch "${FILESDIR}/${P%_pre*}-include-gcc34-fix.patch"
- epatch "${FILESDIR}/${P%_pre*}-gcc41.patch"
- epatch "${FILESDIR}"/${P%_pre*}-gcc43.patch
}
src_install () {