summaryrefslogtreecommitdiffstats
path: root/dev-python/sip4-tqt/sip4-tqt-14.0.13.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-10-28 12:41:56 +0200
committerormorph <roma251078@mail.ru>2022-10-28 19:43:12 +0200
commit345c52699ff344a3bd46c0ee5df765dc404ac3d1 (patch)
tree752a6cb2512e0573cc46d7e89d3575a7a91840c6 /dev-python/sip4-tqt/sip4-tqt-14.0.13.ebuild
parentcc26a6f102600556b4f96fd651ac2b67482e6932 (diff)
downloadtde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.tar.gz
tde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.zip
Added version 14.0.13
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'dev-python/sip4-tqt/sip4-tqt-14.0.13.ebuild')
-rw-r--r--dev-python/sip4-tqt/sip4-tqt-14.0.13.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/sip4-tqt/sip4-tqt-14.0.13.ebuild b/dev-python/sip4-tqt/sip4-tqt-14.0.13.ebuild
new file mode 100644
index 00000000..76339130
--- /dev/null
+++ b/dev-python/sip4-tqt/sip4-tqt-14.0.13.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="dependencies"
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit trinity-base-2 python-single-r1 flag-o-matic
+
+DESCRIPTION="Python/C++ bindings generator runtime library"
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="0"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ ~x11-libs/tqscintilla-${PV}
+ ~dev-tqt/tqtinterface-${PV}
+"
+RDEPEND="${DEPEND}"
+
+TQTDIR="/usr/tqt3"
+BUILD_DIR="${S}"
+
+src_prepare() {
+ eapply_user
+}
+
+src_configure() {
+ local myconf
+ append-cflags "-I/usr/include/tqt -I/${TQTDIR}/include"
+ myconf=(
+ -b "${TDEDIR}/bin"
+ -e "${TDEDIR}/include"
+ )
+ echo yes | "${EPYTHON}" configure.py "${myconf[@]}" CFLAGS="${CFLAGS}" || die
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+}