summaryrefslogtreecommitdiffstats
path: root/media-libs/lcms
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
commit644110a847c5911c2eb04eb53c93031740561efc (patch)
tree9658dde1cc70b52b233957b7852f87d997e98156 /media-libs/lcms
downloadtde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.tar.gz
tde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.zip
Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'media-libs/lcms')
-rw-r--r--media-libs/lcms/Manifest3
-rw-r--r--media-libs/lcms/files/lcms-1.19-disable_static_modules.patch20
-rw-r--r--media-libs/lcms/files/lcms-1.19-implicit.patch49
-rw-r--r--media-libs/lcms/lcms-1.19-r1.ebuild103
-rw-r--r--media-libs/lcms/metadata.xml16
5 files changed, 191 insertions, 0 deletions
diff --git a/media-libs/lcms/Manifest b/media-libs/lcms/Manifest
new file mode 100644
index 00000000..66577068
--- /dev/null
+++ b/media-libs/lcms/Manifest
@@ -0,0 +1,3 @@
+AUX lcms-1.19-disable_static_modules.patch 578 SHA256 bd56a283da65a7ab262d35c890a99e8b103a3a73e50b997e404c3c0ac3ae467e SHA512 fba391dd6d69122217cdcde985d2154dfc2fd9b9aed5a50a013248e024ee54fe07a98acf917fd0e889578616512a2bdf155f0cbe782795e406d96a90b10bbb33 WHIRLPOOL d40c77d18ab5249252e4cadd5b6e2e40c1e43c0f761758908f2afa06d29dce41d56de52d33fe043d7441180c40ca572571fb7c27b87c43406991e5f1e25ff22c
+AUX lcms-1.19-implicit.patch 1308 SHA256 327eb96faafac582362f57800727896bd5c2206a7bb150f12ef7787e84f3ddd9 SHA512 120db0ea4c5a77563dffef55507a8e7fa172ee73ad3943b6ba55c4a01f4a0a2ae21794f4775d58f0d8ba6b5fbdc28c461622416981683063ff746db9a38c724b WHIRLPOOL df45ecfc6fe36db90c676e25f053b370af466648e36e752acfd9f5c0d5acc25a445bf0a8a476f0913ca5c7f0304940c3af35bf56c021fa34045cfdb1e52419bc
+DIST lcms-1.19.tar.gz 927752 SHA256 80ae32cb9f568af4dc7ee4d3c05a4c31fc513fc3e31730fed0ce7378237273a9 SHA512 85a55ad0673f0df2aaa80d18caa50314319f8da5ee4d84eed919059d0dad9861d684ef6353ce0ec6f9892a4603ce8e8e12f84d46858e23f52846b8aefd3cf449 WHIRLPOOL cb6bcb5497798ff2fa86ff433eae6afea38408306345156da6103aa8af6fc0d48fa1d730c5958c027ba06ea023236328bcb00be60f600d987d060625385c820b
diff --git a/media-libs/lcms/files/lcms-1.19-disable_static_modules.patch b/media-libs/lcms/files/lcms-1.19-disable_static_modules.patch
new file mode 100644
index 00000000..15e19eeb
--- /dev/null
+++ b/media-libs/lcms/files/lcms-1.19-disable_static_modules.patch
@@ -0,0 +1,20 @@
+--- a/python/Makefile.am
++++ b/python/Makefile.am
+@@ -22,7 +22,7 @@
+
+ endif
+
+-_lcms_la_LDFLAGS = -no-undefined -module -avoid-version \
++_lcms_la_LDFLAGS = -no-undefined -module -avoid-version -shared \
+ -L$(LCMS_PYLIB)/config
+
+ _lcms_la_LIBADD = $(top_builddir)/src/liblcms.la -lpython$(PYTHON_VERSION)
+@@ -31,7 +31,7 @@
+
+ _lcms_la_CPPFLAGS = -I$(PYTHON_PREFIX)/include/python$(PYTHON_VERSION) \
+ -I$(LCMS_PYINCLUDE) \
+- $(AM_CPPFLAGS)
++ $(AM_CPPFLAGS) -shared
+
+
+ EXTRA_DIST = lcms.py lcms.i testbed swig_lcms
diff --git a/media-libs/lcms/files/lcms-1.19-implicit.patch b/media-libs/lcms/files/lcms-1.19-implicit.patch
new file mode 100644
index 00000000..d8047227
--- /dev/null
+++ b/media-libs/lcms/files/lcms-1.19-implicit.patch
@@ -0,0 +1,49 @@
+cmsio1.c: In function 'AdjustEndianessArray16':
+cmsio1.c:118: warning: implicit declaration of function 'swab'
+testcms.c: In function 'CheckSwab':
+testcms.c:113: warning: implicit declaration of function 'swab'
+================================================================================
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -6,6 +6,9 @@
+ # Don't require all the GNU mandated files
+ AUTOMAKE_OPTIONS = 1.7 foreign
+
++# _XOPEN_SOURCE is required for swab() but undefines strcasecmp(), so add _GNU_SOURCE as well:
++AM_CPPFLAGS = -D_XOPEN_SOURCE -D_GNU_SOURCE
++
+ includedir = ${prefix}/include
+
+ # Shared libraries built in this directory
+--- a/src/cmsio1.c
++++ b/src/cmsio1.c
+@@ -24,6 +24,7 @@
+
+
+ #include "lcms.h"
++#include <unistd.h>
+
+ // ----------------------------------------------------------------- Tag Serialization
+
+--- a/testbed/Makefile.am
++++ b/testbed/Makefile.am
+@@ -6,6 +6,9 @@
+ # Don't require all the GNU mandated files
+ AUTOMAKE_OPTIONS = 1.7 foreign
+
++# Required for swab()
++AM_CPPFLAGS = -D_XOPEN_SOURCE
++
+ INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include
+
+ check_PROGRAMS = testcms
+--- a/testbed/testcms.c
++++ b/testbed/testcms.c
+@@ -36,6 +36,7 @@
+ #include <time.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <unistd.h>
+
+ #ifndef NON_WINDOWS
+ #include <icm.h>
diff --git a/media-libs/lcms/lcms-1.19-r1.ebuild b/media-libs/lcms/lcms-1.19-r1.ebuild
new file mode 100644
index 00000000..d680c905
--- /dev/null
+++ b/media-libs/lcms/lcms-1.19-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit autotools eutils python-r1
+
+DESCRIPTION="A lightweight, speed optimized color management engine"
+HOMEPAGE="http://www.littlecms.com/"
+SRC_URI="http://www.littlecms.com/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="jpeg python static-libs tiff zlib"
+
+RDEPEND="tiff? ( media-libs/tiff:0 )
+ jpeg? ( virtual/jpeg:0 )
+ zlib? ( sys-libs/zlib )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ python? ( >=dev-lang/swig-1.3.31 )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-disable_static_modules.patch"
+ "${FILESDIR}/${P}-implicit.patch"
+)
+
+src_prepare() {
+ # Python bindings are built/installed manually.
+ sed -e "/SUBDIRS =/s/ python//" -i Makefile.am
+
+ default
+
+ eautoreconf
+
+ # run swig to regenerate lcms_wrap.cxx and lcms.py (bug #148728)
+ if use python; then
+ cd python
+ ./swig_lcms || die "swig failed to regenerate files"
+ fi
+}
+
+src_configure() {
+ econf \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --bindir="${EPREFIX}"/usr/bin \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_with jpeg) \
+ $(use_with python) \
+ $(use_with tiff) \
+ $(use_with zlib)
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ local BUILD_DIR
+ BUILD_DIR=python
+
+ python_copy_sources
+
+ building() {
+ emake \
+ LCMS_PYEXECDIR="${EPREFIX}$(python_get_sitedir)" \
+ LCMS_PYINCLUDE="${EPREFIX}$(python_get_includedir)"
+# No corresponding functions in python-r1
+# LCMS_PYLIB="${EPREFIX}$(python_get_libdir)" \
+# PYTHON_VERSION="$(python_get_version)"
+ }
+ python_foreach_impl run_in_build_dir building
+ fi
+}
+
+src_install() {
+ DOCS=(AUTHORS README* INSTALL NEWS doc/*)
+
+ default
+
+ if use python; then
+ local BUILD_DIR
+ BUILD_DIR=python
+
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ LCMS_PYEXECDIR="${EPREFIX}$(python_get_sitedir)" \
+ install
+ }
+ python_foreach_impl run_in_build_dir installation
+ fi
+
+ insinto /usr/share/lcms/profiles
+ doins testbed/*.icm
+
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}
diff --git a/media-libs/lcms/metadata.xml b/media-libs/lcms/metadata.xml
new file mode 100644
index 00000000..8a119fbe
--- /dev/null
+++ b/media-libs/lcms/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fatzer2@gmail.com</email>
+ <name>Alexander Golubev</name>
+ <description>The maintainer of the package in the overlay</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>printing@gentoo.org</email>
+ <name>Gentoo Printing Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">lcms</remote-id>
+ </upstream>
+</pkgmetadata>