summaryrefslogtreecommitdiffstats
path: root/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
commit644110a847c5911c2eb04eb53c93031740561efc (patch)
tree9658dde1cc70b52b233957b7852f87d997e98156 /media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild
downloadtde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.tar.gz
tde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.zip
Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild')
-rw-r--r--media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild b/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild
new file mode 100644
index 00000000..a568e11b
--- /dev/null
+++ b/media-libs/libart_lgpl/libart_lgpl-2.3.21-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="a LGPL version of libart"
+HOMEPAGE="http://www.levien.com/libart"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="virtual/pkgconfig"
+
+# The provided tests are interactive only
+RESTRICT="test"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-static"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix crosscompiling, bug #185684
+ rm "${S}"/art_config.h
+ # NOTE patch is removed automake should handle it
+
+ # Do not build tests if not required
+ epatch "$FILESDIR/0001-gentoo-do-not-build-tests-if-not-required.patch"
+
+ # apply TDE patches
+ epatch "$FILESDIR/0002-TDE-fix-a-number-of-problems.patch"
+ epatch "$FILESDIR/0003-TDE-Clean-up-debug-spew.patch"
+
+ # apply user-provided patches
+ epatch_user
+
+ AT_NOELIBTOOLIZE=yes eautoreconf
+}