summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kbarcode
diff options
context:
space:
mode:
authorE. Liddell <ejlddll@warpmail.net>2020-12-06 16:11:21 -0500
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2021-02-17 16:47:41 +0000
commitf0575f757d3a116ae806b578b37ae4b375a8caf5 (patch)
tree9055d8aa3000cc5d7a90675a7cc27d0d3d54acef /trinity-apps/kbarcode
parent32f776ede66c742cd2dceecb3739b083ac41d92b (diff)
downloadtde-packaging-gentoo-f0575f757d3a116ae806b578b37ae4b375a8caf5.tar.gz
tde-packaging-gentoo-f0575f757d3a116ae806b578b37ae4b375a8caf5.zip
14.0.8 ebuilds for everything in trinity-apps that I could make build back in June.
Signed-off-by: E. Liddell <ejlddll@warpmail.net>
Diffstat (limited to 'trinity-apps/kbarcode')
-rw-r--r--trinity-apps/kbarcode/Manifest2
-rw-r--r--trinity-apps/kbarcode/kbarcode-14.0.8.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/trinity-apps/kbarcode/Manifest b/trinity-apps/kbarcode/Manifest
new file mode 100644
index 00000000..c070c397
--- /dev/null
+++ b/trinity-apps/kbarcode/Manifest
@@ -0,0 +1,2 @@
+DIST kbarcode-trinity-14.0.7.tar.xz 292968 BLAKE2B 4466252fd2473df70fcb4cfc79913d5f6182c82c61ce572103d7f4ff4bcb4a701b2000d07140ae961d4b3d8b7ea98299189160bc922f197b0388cdab5e45c99a SHA512 9fd270ae6f7f24316a92a3cf34f32e6101dd9ff93a285bc3228c67d8f3bbacaacd0fd187d70d36ba55a0c4371eff5e714f2102743dfc6e0e477610f52243451b
+DIST kbarcode-trinity-14.0.8.tar.xz 293940 BLAKE2B 8882da3a4a6ef93b02c9122e3e7ed2a1158b10ada9287177a91318890fb65b9cded53cd8788e7c00299576011b43fbe9cd02d0178a5c3d3f23307e104d4a6490 SHA512 32b8631c6bc1150c335fb142b2c39483fcb7c5df08ee48cea4a5e3f6ac085a24eaed5b93b8e2812d7167f0130ce5fe48fe50df3f21ee164c7b5821bbf3ea64ad
diff --git a/trinity-apps/kbarcode/kbarcode-14.0.8.ebuild b/trinity-apps/kbarcode/kbarcode-14.0.8.ebuild
new file mode 100644
index 00000000..e842c771
--- /dev/null
+++ b/trinity-apps/kbarcode/kbarcode-14.0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de el es fi fr hu it nl pl sv tr"
+
+inherit trinity-base-2
+
+DESCRIPTION="Barcode and label printing application for TDE"
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+# Native GNU Barcode support seems to be broken right now.
+# The GNU Barcode binary is needed anyway.
+
+IUSE+=" javascript native_gnu_barcode"
+
+RDEPEND+=" app-text/barcode
+ || ( media-gfx/imagemagick
+ media-gfx/graphicsmagick )"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_NATIVE_GNU_BARCODE="$(usex native_gnu_barcode)"
+ -DWITH_JAVASCRIPT="$(usex javascript)"
+ )
+
+ trinity-base-2_src_configure
+}