summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kbiff/kbiff-14.1.2.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-28 17:23:47 +0300
committerSlávek Banko <slavek.banko@axis.cz>2024-04-29 00:52:31 +0200
commit94ec1d06986a97431ffc44951e92b075da19b93b (patch)
treed4601e9c08f8d576a5ce043fba5f73020f0c862d /trinity-apps/kbiff/kbiff-14.1.2.ebuild
parent08657933720cc4345cdf62e1d42f199d8225e458 (diff)
downloadtde-packaging-gentoo-94ec1d06986a97431ffc44951e92b075da19b93b.tar.gz
tde-packaging-gentoo-94ec1d06986a97431ffc44951e92b075da19b93b.zip
Add new TDE-14.1.2
Signed-off-by: ormorph <roma251078@mail.ru> (cherry picked from commit 30335515923be5f5ee02981121d2cdb6ad89978d)
Diffstat (limited to 'trinity-apps/kbiff/kbiff-14.1.2.ebuild')
-rw-r--r--trinity-apps/kbiff/kbiff-14.1.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/trinity-apps/kbiff/kbiff-14.1.2.ebuild b/trinity-apps/kbiff/kbiff-14.1.2.ebuild
new file mode 100644
index 00000000..e10185c4
--- /dev/null
+++ b/trinity-apps/kbiff/kbiff-14.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="br cs da de el es et fi fr he hr hu is it ja
+ nb nl nn pl pt pt_BR ro ru sk sl sv tr uk zh_TW"
+TRINITY_MODULE_TYPE="applications/internet"
+inherit trinity-base-2
+
+DESCRIPTION="Email notification utility for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="asus +ssl"
+
+# SSL support might need tdelibs build with +ssl USE.
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_SSL="$(usex ssl)"
+ -DWITH_MLED="$(usex asus)"
+ )
+
+ trinity-base-2_src_configure
+}