summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kbiff
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-22 11:30:51 +0300
committerormorph <roma251078@mail.ru>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /trinity-apps/kbiff
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kbiff')
-rw-r--r--trinity-apps/kbiff/Manifest1
-rw-r--r--trinity-apps/kbiff/kbiff-14.1.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/trinity-apps/kbiff/Manifest b/trinity-apps/kbiff/Manifest
index e70e732e..30d7cf03 100644
--- a/trinity-apps/kbiff/Manifest
+++ b/trinity-apps/kbiff/Manifest
@@ -1 +1,2 @@
DIST kbiff-trinity-14.0.13.tar.xz 139192 BLAKE2B fa17753503a42dec77747db98057fc17dce85d0a222a733be95168c85f5fda11e052f4b98ad612cda75e36b962b81a62fc3fefb03c3e606a7c06f3287f611111 SHA512 00727eba42d138efcaff61020ee1abde7d942d10fb8f482b96afc81c1e63aea813e1aa3d6710d38075355ff7bf316c138437d87cd364eb72f2c3535892c3f972
+DIST kbiff-trinity-14.1.0.tar.xz 139192 BLAKE2B d8be3a3488e50b880410056f64f40b7e27d40869376cbd659c95fbfaf3ff4454d7d30f9509eedb7e1d61bac7591b5e8530385752eddccdb97f943e7790031a07 SHA512 78f86a422acbb8cc04b6229863c14ace3a1643a38d75f3ddc7541f3b4b3186f72874345a3237cfb7d4a1ea2bf76bc471da36885cdc2728a8d6110ac24df22de0
diff --git a/trinity-apps/kbiff/kbiff-14.1.0.ebuild b/trinity-apps/kbiff/kbiff-14.1.0.ebuild
new file mode 100644
index 00000000..a2d82b0b
--- /dev/null
+++ b/trinity-apps/kbiff/kbiff-14.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="br cs da de el es et fi fr he hr hu is it ja
+ nb nl nn pl pt pt_BR ro ru sk sl sv tr uk zh_TW"
+TRINITY_MODULE_TYPE="applications/internet"
+inherit trinity-base-2
+
+DESCRIPTION="Email notification utility for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="asus +ssl"
+
+# SSL support might need tdelibs build with +ssl USE.
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_SSL="$(usex ssl)"
+ -DWITH_MLED="$(usex asus)"
+ )
+
+ trinity-base-2_src_configure
+}