summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kchart
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-22 11:30:51 +0300
committerormorph <roma251078@mail.ru>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /trinity-apps/kchart
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kchart')
-rw-r--r--trinity-apps/kchart/Manifest1
-rw-r--r--trinity-apps/kchart/kchart-14.1.0.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/trinity-apps/kchart/Manifest b/trinity-apps/kchart/Manifest
index f19391fd..46acfcc0 100644
--- a/trinity-apps/kchart/Manifest
+++ b/trinity-apps/kchart/Manifest
@@ -1 +1,2 @@
DIST koffice-trinity-14.0.13.tar.xz 49541404 BLAKE2B 4501137b87772d2e81f251b3f384cfb5417cdb3507786e392a9fe4e98c18806b9749766e51430702432e33773b379184a48f4790c54d17d86b8b6f191b208e5f SHA512 b82e23e653ee07fccdbcda74dc2727e5e0a4cf889794c1319c6985d2133b63e7f92b84dc5fc1727bfc1217bd39c149db66dd2b2fc1762e415e54933561103fe9
+DIST koffice-trinity-14.1.0.tar.xz 49531604 BLAKE2B 1aa5e3b49bdcac1ec7c52f370194d26413409e04db97ab96c8286a4180a37d89b125d083f269c06ab2bdcaadbdc62767da6d70ece8915b57fe5d5c0baed0cca0 SHA512 4dde81ecb3071e07064ffa31aadfcca6755e478904fc66e69f2c914180b65d978cd807b4761073c484c7ddd8f1f81cb312a96d8dfb3d81a5f069db27885a217f
diff --git a/trinity-apps/kchart/kchart-14.1.0.ebuild b/trinity-apps/kchart/kchart-14.1.0.ebuild
new file mode 100644
index 00000000..d9163d8e
--- /dev/null
+++ b/trinity-apps/kchart/kchart-14.1.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2022-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="koffice"
+TRINITY_BUILD_ADMIN="yes"
+TRINITY_SUBMODULE="kchart filters/kchart"
+TSM_EXTRACT_ALSO="lib interfaces filters/libdialogfilter doc"
+
+inherit trinity-meta-2
+
+DESCRIPTION="KOffice integrated graph and chart drawing tool for TDE [Trinity]"
+HOMEPAGE="http://trinitydesktop.org/"
+
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="+handbook"
+
+DEPEND="~trinity-base/tdelibs-${PV}
+ ~trinity-apps/koffice-libs-${PV}
+"
+
+RDEPEND="${DEPEND}
+ handbook? ( ~trinity-base/khelpcenter-${PV}
+ app-doc/doxygen )"
+
+KMCOPYLIB="libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkochart interfaces"
+
+src_unpack() {
+ trinity-meta-2_src_unpack
+ echo "SUBDIRS = kchart" > "${S}/filters/Makefile.am"
+}
+
+src_prepare() {
+ local search_path="${TDEDIR}/${get_libdir}"
+ local libname dirname dirlist x
+ libname=""
+ for x in $KMCOPYLIB; do
+ if [ "${libname}" == "" ] ; then
+ libname="${x}"
+ else
+ dirname=$x
+ mkdir -p ${dirname}
+ pushd ${dirname}
+ if [ ! "$(find ${search_path} -maxdepth 1 -name ${libname}*) 2>/dev/null" == "" ]; then
+ ln -s ${TDEDIR}/$(get_libdir)/${libname}* .
+ if [[ ! ${dirname} =~ "interfaces" ]] ; then
+ dirlist="${dirlist} ${dirname/lib\/}"
+ fi
+ fi
+ popd
+ libname=""
+ fi
+ done
+ if use handbook ; then
+ echo -e "KDE_LANG = en\nSUBDIRS = ${PN}" >"${S}/doc/Makefile.am" || die
+ fi
+ echo "SUBDIRS=$dirlist" > "${S}/lib/Makefile.am"
+ trinity-meta-2_src_prepare
+
+ echo 'all:' > "${S}/Makefile.am"
+ echo 'install:' >> "${S}/Makefile.am"
+ echo '.PHONY: all' >> "${S}/Makefile.am"
+}
+
+src_configure() {
+ trinity-meta-2_src_configure
+}
+
+src_compile() {
+ pushd filters/libdialogfilter
+ emake
+ popd
+ if use handbook ; then
+ TRINITY_SUBMODULE+=" doc"
+ fi
+ trinity-meta-2_src_compile
+}
+
+src_install() {
+ trinity-meta-2_src_install
+ if use handbook ; then
+ pushd "${S}/doc" || die
+ emake install DESTDIR="${D}"
+ popd
+ fi
+}