summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kdbg/kdbg-14.0.11.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2021-12-04 00:41:43 +0300
committerormorph <roma251078@mail.ru>2021-12-04 00:41:43 +0300
commit2eb38c699ebf0ab2f557e36053410ccaa4a64544 (patch)
tree4d0373e39fcc4edf223ddc245df4d4be03912668 /trinity-apps/kdbg/kdbg-14.0.11.ebuild
parent72c259ee0c7859cbdf5b1219bce820b3adaf5ca0 (diff)
downloadtde-packaging-gentoo-2eb38c699ebf0ab2f557e36053410ccaa4a64544.tar.gz
tde-packaging-gentoo-2eb38c699ebf0ab2f557e36053410ccaa4a64544.zip
Added kdbg ebuild
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kdbg/kdbg-14.0.11.ebuild')
-rw-r--r--trinity-apps/kdbg/kdbg-14.0.11.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/trinity-apps/kdbg/kdbg-14.0.11.ebuild b/trinity-apps/kdbg/kdbg-14.0.11.ebuild
new file mode 100644
index 00000000..bdc3154c
--- /dev/null
+++ b/trinity-apps/kdbg/kdbg-14.0.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="br ca cs da de es fi fr is no pl pt_BR pt ro ru sk sl sv"
+TRINITY_MODULE_TYPE="applications/development"
+inherit trinity-base-2
+
+DESCRIPTION="Graphical debugger interface for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}