summaryrefslogtreecommitdiffstats
path: root/trinity-apps/klamav/klamav-9999.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-10-30 07:16:02 +0000
committerormorph <roma251078@mail.ru>2022-10-30 07:30:01 +0000
commitbec0b51e483566799b64530571e1ff6b633feaeb (patch)
treec5936197a4725c3695c7373edd9839cf5c31f1e4 /trinity-apps/klamav/klamav-9999.ebuild
parent345c52699ff344a3bd46c0ee5df765dc404ac3d1 (diff)
downloadtde-packaging-gentoo-bec0b51e483566799b64530571e1ff6b633feaeb.tar.gz
tde-packaging-gentoo-bec0b51e483566799b64530571e1ff6b633feaeb.zip
Added klamav ebuilds
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/klamav/klamav-9999.ebuild')
-rw-r--r--trinity-apps/klamav/klamav-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/trinity-apps/klamav/klamav-9999.ebuild b/trinity-apps/klamav/klamav-9999.ebuild
new file mode 100644
index 00000000..cbaf1004
--- /dev/null
+++ b/trinity-apps/klamav/klamav-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="el eo it pt ru"
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="KlamAV - A TDE front-end for the ClamAV virus scanner"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ app-antivirus/clamav
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}