summaryrefslogtreecommitdiffstats
path: root/trinity-apps/klamav
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-22 11:30:51 +0300
committerormorph <roma251078@mail.ru>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /trinity-apps/klamav
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/klamav')
-rw-r--r--trinity-apps/klamav/Manifest1
-rw-r--r--trinity-apps/klamav/klamav-14.1.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/trinity-apps/klamav/Manifest b/trinity-apps/klamav/Manifest
index 24e87c85..1f02d917 100644
--- a/trinity-apps/klamav/Manifest
+++ b/trinity-apps/klamav/Manifest
@@ -1 +1,2 @@
DIST klamav-trinity-14.0.13.tar.xz 645840 BLAKE2B 0d60f2e9a9331127f92d0232a8373b6f9e4cf5779bfccb64f89ec67582750d9b28469a904e0b2c68e39e47ed022a44ba27514ec1bbe8200465040086c9406dd8 SHA512 f876bd998b227914c68274fbd3232081065437e25b695eeebb4e10cbc26995f2b80d84e67c35e96a41f014f60c83541243871b579df947b5e7b6a4b3211ae20a
+DIST klamav-trinity-14.1.0.tar.xz 646064 BLAKE2B d17cb9fcffe719d28635bd95f46a7c15937d3399809bb376ccd26bb7dd3556866f7ea33bc9e89465a29bca8a649f0691f8778406ec25fff6f6726e35c5e9a4fa SHA512 b586767b6bb3b4249f65379fae3b0a1b8eef9a49fdadccf805c222c2c62794243b31927e4f61a2f3562947fb3e33401dcbb2dfcc7c72048179490066359214e2
diff --git a/trinity-apps/klamav/klamav-14.1.0.ebuild b/trinity-apps/klamav/klamav-14.1.0.ebuild
new file mode 100644
index 00000000..59a53e02
--- /dev/null
+++ b/trinity-apps/klamav/klamav-14.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="el eo it pt ru"
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="KlamAV - A TDE front-end for the ClamAV virus scanner"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+RDEPEND="
+ app-antivirus/clamav
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}