summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kmplayer/kmplayer-14.1.1.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-12-18 21:10:28 +0300
committerormorph <roma251078@mail.ru>2023-12-18 21:10:28 +0300
commite1cce88d17cc1b2cdcbf6b9d3612d4483324cd70 (patch)
treef38166624e20b603ab579b066a60b5c162153e55 /trinity-apps/kmplayer/kmplayer-14.1.1.ebuild
parent66eb8ae997c7ae1c6096091546d3d1e9bd855c49 (diff)
downloadtde-packaging-gentoo-e1cce88d17cc1b2cdcbf6b9d3612d4483324cd70.tar.gz
tde-packaging-gentoo-e1cce88d17cc1b2cdcbf6b9d3612d4483324cd70.zip
Added kmplayer ebuilds
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kmplayer/kmplayer-14.1.1.ebuild')
-rw-r--r--trinity-apps/kmplayer/kmplayer-14.1.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/trinity-apps/kmplayer/kmplayer-14.1.1.ebuild b/trinity-apps/kmplayer/kmplayer-14.1.1.ebuild
new file mode 100644
index 00000000..c2bced69
--- /dev/null
+++ b/trinity-apps/kmplayer/kmplayer-14.1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="af ar be bg br bs ca csb cs cy da de el es et \
+ fi fr ga gl he hi hu it ja ka lt mk nb nl pa \
+ pt_BR pt ru rw sk sr sv ta th tr uk xh zh_CN \
+ zh_TW zu"
+
+TRINITY_DOC_LANGS="da de es et fr it nl pt ru sv"
+
+TRINITY_MODULE_TYPE="applications/multimedia"
+inherit trinity-base-2
+
+DESCRIPTION="MPlayer - a simple media player for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="gstreamer koffice xine"
+
+DEPEND="media-video/ffmpeg
+ media-video/mplayer
+ koffice? ( ~trinity-apps/koffice-meta-${PV} )
+ gstreamer? ( media-plugins/gst-plugins-meta )
+ xine? ( media-libs/xine-lib )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DBUILD_KOFFICE_PLUGIN="$(usex koffice)"
+ -DBUILD_KXVPLAYER="$(usex gstreamer)"
+ -DBUILD_KXINEPLAYER="$(usex xine)"
+ )
+ trinity-base-2_src_configure
+}