summaryrefslogtreecommitdiffstats
path: root/trinity-apps/knemo/knemo-14.1.0.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-22 11:30:51 +0300
committerormorph <roma251078@mail.ru>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /trinity-apps/knemo/knemo-14.1.0.ebuild
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/knemo/knemo-14.1.0.ebuild')
-rw-r--r--trinity-apps/knemo/knemo-14.1.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/trinity-apps/knemo/knemo-14.1.0.ebuild b/trinity-apps/knemo/knemo-14.1.0.ebuild
new file mode 100644
index 00000000..fc0f6389
--- /dev/null
+++ b/trinity-apps/knemo/knemo-14.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg cs cy da de el es et fr ga gl hu it
+ ja ka lt nl pl pt pt_BR ru rw sk sr sr@Latn sv tr"
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="Network interfaces monitor for the TDE systray"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="wifi kernel_linux"
+
+RDEPEND="kernel_linux? ( sys-apps/net-tools )
+ wifi? ( net-wireless/wireless-tools )"
+
+pkg_postinst() {
+ echo
+ einfo "KNemo is not an executable but a KDED service. KNemo has to be"
+ einfo "started using TDE Control Center/Internet & Network/Network Monitor"
+ echo
+}