summaryrefslogtreecommitdiffstats
path: root/trinity-apps/knmap
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2021-11-15 22:06:35 +0300
committerormorph <roma251078@mail.ru>2021-11-16 00:22:50 +0300
commit9f59a1d0c834bc706d6e74f0a0dc9f026e935b41 (patch)
treedbe2babfd8aea5f985063e94dcfa22679c93526f /trinity-apps/knmap
parentffbff856abb47b6fb62cdd430211c67f67478c5b (diff)
downloadtde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.tar.gz
tde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.zip
Added ebuilds for stable version 14.0.11
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/knmap')
-rw-r--r--trinity-apps/knmap/Manifest1
-rw-r--r--trinity-apps/knmap/knmap-14.0.11.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/trinity-apps/knmap/Manifest b/trinity-apps/knmap/Manifest
index 11a6d299..a07100b0 100644
--- a/trinity-apps/knmap/Manifest
+++ b/trinity-apps/knmap/Manifest
@@ -1 +1,2 @@
+DIST knmap-trinity-14.0.11.tar.xz 981044 BLAKE2B 5a03a46739dc0f486aa021a2600efd169e5dcc292407624501957e18a5e01b7c6d4c50130612716970e57bc1f6d10972437603dce0a9c3b0d7f2d942215f441b SHA512 1e59b94c1e4e95cc559ca272e4f3ccdab41e09751357aa32f98fe16d0be968efb0871c37fb9dd8702bea91acde735158fd7db5db6387f82e027a7c64b949199c
DIST knmap-trinity-14.0.8.tar.xz 1001756 BLAKE2B e869e1581fa93ebaec226ff6125e76395e8a679d7fe8b6dcbd27fbce4f351d8dffe77094d1a4a6987cb0ec8a6fec98d146b621bb2d0b5a032766d7f84c1c7e59 SHA512 53c24572b2383e5360c6d38817d9eab8ac5f67d5f75cf75de849819ca197d817a1b44c4865e7044477d0a698e610a0f432e6b9888c7bc2ef571956c0b3511d40
diff --git a/trinity-apps/knmap/knmap-14.0.11.ebuild b/trinity-apps/knmap/knmap-14.0.11.ebuild
new file mode 100644
index 00000000..41a63ae0
--- /dev/null
+++ b/trinity-apps/knmap/knmap-14.0.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+TRINITY_MODULE_TYPE="applications/internet"
+inherit trinity-base-2
+
+DESCRIPTION="Nmap graphical interface for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="net-analyzer/nmap"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}