summaryrefslogtreecommitdiffstats
path: root/trinity-apps/koffice-i18n
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-10-28 12:41:56 +0200
committerormorph <roma251078@mail.ru>2022-10-28 19:43:12 +0200
commit345c52699ff344a3bd46c0ee5df765dc404ac3d1 (patch)
tree752a6cb2512e0573cc46d7e89d3575a7a91840c6 /trinity-apps/koffice-i18n
parentcc26a6f102600556b4f96fd651ac2b67482e6932 (diff)
downloadtde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.tar.gz
tde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.zip
Added version 14.0.13
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/koffice-i18n')
-rw-r--r--trinity-apps/koffice-i18n/Manifest1
-rw-r--r--trinity-apps/koffice-i18n/koffice-i18n-14.0.13.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/trinity-apps/koffice-i18n/Manifest b/trinity-apps/koffice-i18n/Manifest
index 67534896..7add08f3 100644
--- a/trinity-apps/koffice-i18n/Manifest
+++ b/trinity-apps/koffice-i18n/Manifest
@@ -1 +1,2 @@
DIST koffice-i18n-trinity-14.0.12.tar.xz 44079848 BLAKE2B f89411859b57abf9716b5709d7247305279ca6f8f4944836eeffd6d09004e1af14e51d20f82418fb1b6499855054947a2b015b339cbcbe4cd35c9be29c294195 SHA512 063fcd3479a3a55dfb3ca540a1414e382cd9b612600c4037a953518c7767514b992bafcf6edfd78e15c2f50a65ae244a4e35b872922c39b326f5803c37e8029c
+DIST koffice-i18n-trinity-14.0.13.tar.xz 44081236 BLAKE2B b44d7f9263097ed251efd1eddd5a4b2ed7f1176725d0e36c2a574adb9db4d349ed7d33069aabc44737accd847443b692355c12edac6bf3835d7fcaa9dbf3c6a0 SHA512 c5272ddbddd36890bd50d12ddb0a28b766fd731fd13549f4fd7d3d215f806b004d86ef55df390f7cf4a698fa8a9251dfe949c908abffc572b0596d3aad3f9553
diff --git a/trinity-apps/koffice-i18n/koffice-i18n-14.0.13.ebuild b/trinity-apps/koffice-i18n/koffice-i18n-14.0.13.ebuild
new file mode 100644
index 00000000..7ab58563
--- /dev/null
+++ b/trinity-apps/koffice-i18n/koffice-i18n-14.0.13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_TYPE="applications/office"
+
+inherit trinity-base-2
+
+DESCRIPTION="TDE internationalization package for Koffice [Trinity]"
+HOMEPAGE="http://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE=""
+
+TRINITY_LANGS="bg ca cs cy da de el en_GB es et eu fa fi
+ fr ga gl hu it ja km lv ms nb nds ne nl pl pt pt_BR
+ ru sk sl sr sr@Latn sv tr uk zh_CN zh_TW"
+
+for X in ${TRINITY_LANGS} ; do
+ IUSE="${IUSE} l10n_${X}"
+done
+
+DEPEND="
+ ~trinity-base/tdelibs-${PV}
+"
+RDEPEND="${DEPEND}"
+
+LINGUAS="en"
+
+find_lang() {
+ local lang
+ lang=${1}
+ LINGUAS+=" ${lang}"
+}
+
+src_prepare() {
+ trinity_l10n_for_each_locale_do find_lang
+ trinity-base-2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_ALL=ON )
+ trinity-base-2_src_configure
+}
+
+src_install() {
+ [[ "${LINGUAS}" == "en" ]] && return 0
+ trinity-base-2_src_install
+}