summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kompose/kompose-14.1.0.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-25 14:44:32 +0300
committerormorph <roma251078@mail.ru>2023-04-25 15:31:45 +0300
commit48e81b686bc71329df6a9e9dcd001badd6e8c4e2 (patch)
tree70d68123b3c6eda9a4746b497080e3bb05ae6dfa /trinity-apps/kompose/kompose-14.1.0.ebuild
parentd61b990d16400a990fcc10f6b8b251f84a98479a (diff)
downloadtde-packaging-gentoo-3325b862b389d5fd1efd8a374820f3e78e23b502.tar.gz
tde-packaging-gentoo-3325b862b389d5fd1efd8a374820f3e78e23b502.zip
Added new ebuilds: polkit-tqt, polkit-agent-tde, tdebluez, tdesshaskpass, tdeio-appinfo, tdepacman, kompose, mathemagics, twin-style-machbuntr14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kompose/kompose-14.1.0.ebuild')
-rw-r--r--trinity-apps/kompose/kompose-14.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/trinity-apps/kompose/kompose-14.1.0.ebuild b/trinity-apps/kompose/kompose-14.1.0.ebuild
new file mode 100644
index 00000000..f9636d72
--- /dev/null
+++ b/trinity-apps/kompose/kompose-14.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="da de el es fr it"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Full-Screen Task Manager for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="xcomposite"
+
+DEPEND="media-libs/imlib2
+ xcomposite? ( x11-libs/libXcomposite
+ x11-libs/libXdamage )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_XCOMPOSITE="$(usex xcomposite)"
+ )
+ trinity-base-2_src_configure
+}