summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kompose
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-25 14:44:32 +0300
committerormorph <roma251078@mail.ru>2023-04-25 15:31:45 +0300
commit48e81b686bc71329df6a9e9dcd001badd6e8c4e2 (patch)
tree70d68123b3c6eda9a4746b497080e3bb05ae6dfa /trinity-apps/kompose
parentd61b990d16400a990fcc10f6b8b251f84a98479a (diff)
downloadtde-packaging-gentoo-48e81b686bc71329df6a9e9dcd001badd6e8c4e2.tar.gz
tde-packaging-gentoo-48e81b686bc71329df6a9e9dcd001badd6e8c4e2.zip
Added new ebuilds: polkit-tqt, polkit-agent-tde, tdebluez, tdesshaskpass, tdeio-appinfo, tdepacman, kompose, mathemagics, twin-style-machbuntr14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kompose')
-rw-r--r--trinity-apps/kompose/Manifest1
-rw-r--r--trinity-apps/kompose/kompose-14.1.0.ebuild36
-rw-r--r--trinity-apps/kompose/kompose-9999.ebuild36
-rw-r--r--trinity-apps/kompose/metadata.xml8
4 files changed, 81 insertions, 0 deletions
diff --git a/trinity-apps/kompose/Manifest b/trinity-apps/kompose/Manifest
new file mode 100644
index 00000000..19a292cd
--- /dev/null
+++ b/trinity-apps/kompose/Manifest
@@ -0,0 +1 @@
+DIST kompose-trinity-14.1.0.tar.xz 76396 BLAKE2B f666c3798a0c556966c48891538ab93ca6005e111f4c9f3fd639005d7d174084553cf59e0764480d3ec186ac41dcbb8572aa70962279c3b2dcaf75827644d819 SHA512 6c8e5c8e8541c20ab738820a0a86b307e4e6b5243824a564609b119b40a94f42c99ca4a0f27f8c5c430b266b7f283b32cbbf63c6d676b5a8f7be298b114f4e05
diff --git a/trinity-apps/kompose/kompose-14.1.0.ebuild b/trinity-apps/kompose/kompose-14.1.0.ebuild
new file mode 100644
index 00000000..f9636d72
--- /dev/null
+++ b/trinity-apps/kompose/kompose-14.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="da de el es fr it"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Full-Screen Task Manager for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="xcomposite"
+
+DEPEND="media-libs/imlib2
+ xcomposite? ( x11-libs/libXcomposite
+ x11-libs/libXdamage )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_XCOMPOSITE="$(usex xcomposite)"
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/kompose/kompose-9999.ebuild b/trinity-apps/kompose/kompose-9999.ebuild
new file mode 100644
index 00000000..d4ace5ad
--- /dev/null
+++ b/trinity-apps/kompose/kompose-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="da de el es fr it"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Full-Screen Task Manager for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="xcomposite"
+
+DEPEND="media-libs/imlib2
+ xcomposite? ( x11-libs/libXcomposite
+ x11-libs/libXdamage )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_XCOMPOSITE="$(usex xcomposite)"
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/kompose/metadata.xml b/trinity-apps/kompose/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-apps/kompose/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>