summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kompose
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-10-27 13:50:17 +0300
committerSlávek Banko <slavek.banko@axis.cz>2023-10-29 10:05:05 +0100
commit271fc0de62480ffa8a1525e07b833079c96ca6bd (patch)
treefe24a566266198330ff71db390413fdf7a9d63af /trinity-apps/kompose
parent8e955e3a507fd32d4b98df0893bb2dfa83b48eb8 (diff)
downloadtde-packaging-gentoo-271fc0de62480ffa8a1525e07b833079c96ca6bd.tar.gz
tde-packaging-gentoo-271fc0de62480ffa8a1525e07b833079c96ca6bd.zip
Release R14.1.1 added
Signed-off-by: ormorph <roma251078@mail.ru> (cherry picked from commit 18d39ed9f062321b596258a9137f10b3e93b71e0)
Diffstat (limited to 'trinity-apps/kompose')
-rw-r--r--trinity-apps/kompose/Manifest1
-rw-r--r--trinity-apps/kompose/kompose-14.1.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/trinity-apps/kompose/Manifest b/trinity-apps/kompose/Manifest
index 19a292cd..d6dc8ef4 100644
--- a/trinity-apps/kompose/Manifest
+++ b/trinity-apps/kompose/Manifest
@@ -1 +1,2 @@
DIST kompose-trinity-14.1.0.tar.xz 76396 BLAKE2B f666c3798a0c556966c48891538ab93ca6005e111f4c9f3fd639005d7d174084553cf59e0764480d3ec186ac41dcbb8572aa70962279c3b2dcaf75827644d819 SHA512 6c8e5c8e8541c20ab738820a0a86b307e4e6b5243824a564609b119b40a94f42c99ca4a0f27f8c5c430b266b7f283b32cbbf63c6d676b5a8f7be298b114f4e05
+DIST kompose-trinity-14.1.1.tar.xz 76384 BLAKE2B 782d709fab1cac52c6c087c0b95f9f224b40e1b8663daecc36d8198cf17926c51ff57584c69078b887973bc8a4e818a80afb92be4edd8d7b5d1cee6a0357886c SHA512 daef4f3cec7ae31d2fd62708ae54f2e6c2b7602a6bc75b64e005d80ba1bd059ef7175e3bf9701d94f195bbe3e7a1fae6ca0443576e72260f3a3e2e66596c3b7a
diff --git a/trinity-apps/kompose/kompose-14.1.1.ebuild b/trinity-apps/kompose/kompose-14.1.1.ebuild
new file mode 100644
index 00000000..f9636d72
--- /dev/null
+++ b/trinity-apps/kompose/kompose-14.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="da de el es fr it"
+
+TRINITY_MODULE_TYPE="applications/utilities"
+inherit trinity-base-2
+
+DESCRIPTION="Full-Screen Task Manager for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="xcomposite"
+
+DEPEND="media-libs/imlib2
+ xcomposite? ( x11-libs/libXcomposite
+ x11-libs/libXdamage )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DWITH_XCOMPOSITE="$(usex xcomposite)"
+ )
+ trinity-base-2_src_configure
+}