summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kscope
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2021-11-15 22:06:35 +0300
committerormorph <roma251078@mail.ru>2021-11-16 00:22:50 +0300
commit9f59a1d0c834bc706d6e74f0a0dc9f026e935b41 (patch)
treedbe2babfd8aea5f985063e94dcfa22679c93526f /trinity-apps/kscope
parentffbff856abb47b6fb62cdd430211c67f67478c5b (diff)
downloadtde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.tar.gz
tde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.zip
Added ebuilds for stable version 14.0.11
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kscope')
-rw-r--r--trinity-apps/kscope/Manifest1
-rw-r--r--trinity-apps/kscope/kscope-14.0.11.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/trinity-apps/kscope/Manifest b/trinity-apps/kscope/Manifest
new file mode 100644
index 00000000..f9e054dd
--- /dev/null
+++ b/trinity-apps/kscope/Manifest
@@ -0,0 +1 @@
+DIST kscope-trinity-14.0.11.tar.xz 1059068 BLAKE2B 746a659e8ce098941f6c6efad7f58397d7ad2dcc2959b84ce12dee416be88b88f7c7679dd424a93a65fee232a3a3b110514ccbbe8fa25d9f98545cb87d3c979f SHA512 5fa6d925819bf7173e9f4cdbeba9b223c0b31028c6741497675c28bc5d6c05e94f071734e407c86c2f0388d9a241ba5fd24bf0c5a134dd9609413f3407081bcd
diff --git a/trinity-apps/kscope/kscope-14.0.11.ebuild b/trinity-apps/kscope/kscope-14.0.11.ebuild
new file mode 100644
index 00000000..833f4b67
--- /dev/null
+++ b/trinity-apps/kscope/kscope-14.0.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de zh_CN"
+TRINITY_MODULE_TYPE="applications/development"
+inherit trinity-base-2
+
+DESCRIPTION="TDE front-end to Cscope"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ media-gfx/graphviz
+ dev-util/cscope
+ dev-util/ctags
+ ~trinity-base/kate-${PV}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}