summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kscope
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-04-30 20:47:27 +0300
committerSlávek Banko <slavek.banko@axis.cz>2022-05-01 16:23:29 +0200
commit336d8ce82c00a00153a823a187dbc8e0bcf2c7a1 (patch)
tree920bb9b62e96c92b2a5a7e99352e68afb2783ce8 /trinity-apps/kscope
parent1c8d53512742aab368c0f7e9973604eaa54b43ba (diff)
downloadtde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.tar.gz
tde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.zip
Added version 14.0.12
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kscope')
-rw-r--r--trinity-apps/kscope/Manifest1
-rw-r--r--trinity-apps/kscope/kscope-14.0.12.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/trinity-apps/kscope/Manifest b/trinity-apps/kscope/Manifest
index f9e054dd..d93d4f95 100644
--- a/trinity-apps/kscope/Manifest
+++ b/trinity-apps/kscope/Manifest
@@ -1 +1,2 @@
DIST kscope-trinity-14.0.11.tar.xz 1059068 BLAKE2B 746a659e8ce098941f6c6efad7f58397d7ad2dcc2959b84ce12dee416be88b88f7c7679dd424a93a65fee232a3a3b110514ccbbe8fa25d9f98545cb87d3c979f SHA512 5fa6d925819bf7173e9f4cdbeba9b223c0b31028c6741497675c28bc5d6c05e94f071734e407c86c2f0388d9a241ba5fd24bf0c5a134dd9609413f3407081bcd
+DIST kscope-trinity-14.0.12.tar.xz 1059112 BLAKE2B 56bb77aa434613daedce9be465ec1d4a4c3de10ba1219b49edb26b281749bc640f8cf817d8b418da64ed07bd5b3d2664284f4f2dc433d8df50811e1ab0220f49 SHA512 040147366b0ffe9b1095718b47a02c7b0dfeeca9dac3bcdef097fecedf4e4f774f3c199fff8f6d8473abcc46665ab8da5494381ee670271d7a35606e23072016
diff --git a/trinity-apps/kscope/kscope-14.0.12.ebuild b/trinity-apps/kscope/kscope-14.0.12.ebuild
new file mode 100644
index 00000000..f9a19f20
--- /dev/null
+++ b/trinity-apps/kscope/kscope-14.0.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de zh_CN"
+TRINITY_MODULE_TYPE="applications/development"
+inherit trinity-base-2
+
+DESCRIPTION="TDE front-end to Cscope"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+RDEPEND="
+ media-gfx/graphviz
+ dev-util/cscope
+ dev-util/ctags
+ ~trinity-base/kate-${PV}
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}