summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kshutdown
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2021-11-15 22:06:35 +0300
committerormorph <roma251078@mail.ru>2021-11-16 00:22:50 +0300
commit9f59a1d0c834bc706d6e74f0a0dc9f026e935b41 (patch)
treedbe2babfd8aea5f985063e94dcfa22679c93526f /trinity-apps/kshutdown
parentffbff856abb47b6fb62cdd430211c67f67478c5b (diff)
downloadtde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.tar.gz
tde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.zip
Added ebuilds for stable version 14.0.11
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/kshutdown')
-rw-r--r--trinity-apps/kshutdown/Manifest1
-rw-r--r--trinity-apps/kshutdown/kshutdown-14.0.11.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/trinity-apps/kshutdown/Manifest b/trinity-apps/kshutdown/Manifest
index 6280c260..b8e4117d 100644
--- a/trinity-apps/kshutdown/Manifest
+++ b/trinity-apps/kshutdown/Manifest
@@ -1 +1,2 @@
+DIST kshutdown-trinity-14.0.11.tar.xz 172464 BLAKE2B 0d88dc9da0e8ae374c7812c55694c109bd53f777f8e1bf9e3216569ddb6d5415aff4e744efc87cbf292b1e7f1b77cf448c6e7384bc42cb388c75a8876d44fef4 SHA512 6432b5af45b0258e7b1ee89ce70e5001cf80600c4d47ac587107c3f75266e5e793c6acf2cbd5aa9479813af1ac4699a561f944f4f19c1d7b3b57b7b0ac3c2ff5
DIST kshutdown-trinity-14.0.8.tar.xz 193928 BLAKE2B 97ad5c5f80adcfeadc72ecbbf1c7b6d1c728814a1597ec5c9b0034d70b8d2cfa8f69b935becb89e850c7617664d6846e1f4d674481f6b30c9c6423d25e993fcb SHA512 d12f541e89581c0567a39c6939fe0e7aca1594930b78f33d0311ea08e9a9dd7c378b86fb22ad50be82f89726e11ea2249271c4362035ea4445b8ae96a617e435
diff --git a/trinity-apps/kshutdown/kshutdown-14.0.11.ebuild b/trinity-apps/kshutdown/kshutdown-14.0.11.ebuild
new file mode 100644
index 00000000..d0faf516
--- /dev/null
+++ b/trinity-apps/kshutdown/kshutdown-14.0.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ar bg cs de es fr hu it nl pl pt_BR ru sk sv tr zh_CN"
+
+TRINITY_DOC_LANGS="de"
+TRINITY_MODULE_TYPE="applications/system"
+inherit trinity-base-2
+
+DESCRIPTION="A graphical shutdown utility for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="extras"
+
+RDEPEND="
+ ~trinity-base/kcontrol-${PV}
+ ~trinity-base/kdialog-${PV}
+ ~trinity-base/tdesu-${PV}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ -DBUILD_EXTRAS="$(usex extras)"
+ )
+
+ trinity-base-2_src_configure
+}