summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdeio-sword
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-04-30 20:47:27 +0300
committerSlávek Banko <slavek.banko@axis.cz>2022-05-01 16:23:29 +0200
commit336d8ce82c00a00153a823a187dbc8e0bcf2c7a1 (patch)
tree920bb9b62e96c92b2a5a7e99352e68afb2783ce8 /trinity-apps/tdeio-sword
parent1c8d53512742aab368c0f7e9973604eaa54b43ba (diff)
downloadtde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.tar.gz
tde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.zip
Added version 14.0.12
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/tdeio-sword')
-rw-r--r--trinity-apps/tdeio-sword/Manifest1
-rw-r--r--trinity-apps/tdeio-sword/tdeio-sword-14.0.12.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/trinity-apps/tdeio-sword/Manifest b/trinity-apps/tdeio-sword/Manifest
index 0bfd4aee..3c3bfddf 100644
--- a/trinity-apps/tdeio-sword/Manifest
+++ b/trinity-apps/tdeio-sword/Manifest
@@ -1 +1,2 @@
DIST tdeio-sword-trinity-14.0.11.tar.xz 102640 BLAKE2B 0f92305fc50244a04bba50adbef508c846ccefafb9b283978ab583aa31edaa3d3aa32c2f501ed24f8f362a51d29272ed236428539bf860b168d43963ffebb075 SHA512 e8e4c6bd83353123a45fd46fe0eccbc7fa4eb8d8b7d1a5a0c39ba64fb7aeb088205e949cfb245cb326026959665504879256ffc9f45b85ba1bad054455bd5d35
+DIST tdeio-sword-trinity-14.0.12.tar.xz 102736 BLAKE2B 9bb9b4ad321167c5aaa14457f769d7a618f8f39dc2565b5a7277342ff201de8adb737a84eb6f44b7722c01ccdef0e319b64ed38a72c55c33327ee01af74eccd9 SHA512 b9661d89fcb94ba26ebd19e343c5816fba8a3af6d861026fd6eb8cede8d60e2f7fbc6dcbdb816122e571e81b8e3125f70a936a367c7a4376e9617a0612aeea46
diff --git a/trinity-apps/tdeio-sword/tdeio-sword-14.0.12.ebuild b/trinity-apps/tdeio-sword/tdeio-sword-14.0.12.ebuild
new file mode 100644
index 00000000..8a878adc
--- /dev/null
+++ b/trinity-apps/tdeio-sword/tdeio-sword-14.0.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+
+TRINITY_MODULE_TYPE="applications/tdeio"
+inherit trinity-base-2
+
+DESCRIPTION="Sword TDEIO plugin"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="app-text/sword"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
+
+pkg_postinst() {
+ elog "It is recommended that you have modules installed for sword."
+ elog "Gentoo provides the \"sword-modules\" package for convenience:"
+ elog "\temerge sword-modules"
+}