summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdeio-sword
diff options
context:
space:
mode:
authorE. Liddell <ejlddll@warpmail.net>2020-12-06 16:11:21 -0500
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2021-02-17 16:47:41 +0000
commitf0575f757d3a116ae806b578b37ae4b375a8caf5 (patch)
tree9055d8aa3000cc5d7a90675a7cc27d0d3d54acef /trinity-apps/tdeio-sword
parent32f776ede66c742cd2dceecb3739b083ac41d92b (diff)
downloadtde-packaging-gentoo-f0575f757d3a116ae806b578b37ae4b375a8caf5.tar.gz
tde-packaging-gentoo-f0575f757d3a116ae806b578b37ae4b375a8caf5.zip
14.0.8 ebuilds for everything in trinity-apps that I could make build back in June.
Signed-off-by: E. Liddell <ejlddll@warpmail.net>
Diffstat (limited to 'trinity-apps/tdeio-sword')
-rw-r--r--trinity-apps/tdeio-sword/Manifest2
-rw-r--r--trinity-apps/tdeio-sword/tdeio-sword-14.0.8.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/trinity-apps/tdeio-sword/Manifest b/trinity-apps/tdeio-sword/Manifest
new file mode 100644
index 00000000..d360d001
--- /dev/null
+++ b/trinity-apps/tdeio-sword/Manifest
@@ -0,0 +1,2 @@
+DIST tdeio-sword-trinity-14.0.7.tar.xz 373224 BLAKE2B 08aa5c5889c762ff53345a7b85d7f6b4d44ec1c92bc4867a2a7cec22147dc76d739e14280b4c82003a6b41161e1529244f5c50572af62bfd43083d92c701bd6a SHA512 5dea2684984e0489f181328f2d90a5e35aedb55e7a760d249cc45c4d94c945b6300417ec888c38096e3f45ec72ca416965f081059c765ed2250ee3d7b6b83aa5
+DIST tdeio-sword-trinity-14.0.8.tar.xz 375116 BLAKE2B 8e4ba3d765c97a592f9d648165f0bece5c6756214148a0305f063d97b06b85aa7bb19d8f19e94b69300e130b552f170943e3be163ff49829049973e82fed01c5 SHA512 06cc2fa173a9a3e0a9c584f2712aa57f8c5fcc5d7135b4f283f375fdd8f5205685d8a84f90879797035b876eaf82abea8a83317b286f21d16d8a30138218c7a3
diff --git a/trinity-apps/tdeio-sword/tdeio-sword-14.0.8.ebuild b/trinity-apps/tdeio-sword/tdeio-sword-14.0.8.ebuild
new file mode 100644
index 00000000..982fc600
--- /dev/null
+++ b/trinity-apps/tdeio-sword/tdeio-sword-14.0.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+
+inherit trinity-base-2
+
+DESCRIPTION="Sword TDEIO plugin"
+KEYWORDS="~amd64 ~x86"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+DEPEND+=" app-text/sword"
+RDEPEND+=" ${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}
+
+pkg_postinst() {
+ elog "It is recommended that you have modules installed for sword."
+ elog "Gentoo provides the \"sword-modules\" package for convenience:"
+ elog "\temerge sword-modules"
+}