summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdepacman/tdepacman-9999.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-25 14:44:32 +0300
committerormorph <roma251078@mail.ru>2023-04-25 15:31:45 +0300
commit48e81b686bc71329df6a9e9dcd001badd6e8c4e2 (patch)
tree70d68123b3c6eda9a4746b497080e3bb05ae6dfa /trinity-apps/tdepacman/tdepacman-9999.ebuild
parentd61b990d16400a990fcc10f6b8b251f84a98479a (diff)
downloadtde-packaging-gentoo-48e81b686bc71329df6a9e9dcd001badd6e8c4e2.tar.gz
tde-packaging-gentoo-48e81b686bc71329df6a9e9dcd001badd6e8c4e2.zip
Added new ebuilds: polkit-tqt, polkit-agent-tde, tdebluez, tdesshaskpass, tdeio-appinfo, tdepacman, kompose, mathemagics, twin-style-machbuntr14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/tdepacman/tdepacman-9999.ebuild')
-rw-r--r--trinity-apps/tdepacman/tdepacman-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/trinity-apps/tdepacman/tdepacman-9999.ebuild b/trinity-apps/tdepacman/tdepacman-9999.ebuild
new file mode 100644
index 00000000..3e167f47
--- /dev/null
+++ b/trinity-apps/tdepacman/tdepacman-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de es he pt sv"
+TRINITY_MODULE_TYPE="applications/games"
+inherit trinity-base-2
+
+DESCRIPTION="A pacman game for the Trinity Desktop"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="~trinity-base/libtdegames-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}