summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdepacman
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-25 14:44:32 +0300
committerormorph <roma251078@mail.ru>2023-04-25 15:31:45 +0300
commit48e81b686bc71329df6a9e9dcd001badd6e8c4e2 (patch)
tree70d68123b3c6eda9a4746b497080e3bb05ae6dfa /trinity-apps/tdepacman
parentd61b990d16400a990fcc10f6b8b251f84a98479a (diff)
downloadtde-packaging-gentoo-3325b862b389d5fd1efd8a374820f3e78e23b502.tar.gz
tde-packaging-gentoo-3325b862b389d5fd1efd8a374820f3e78e23b502.zip
Added new ebuilds: polkit-tqt, polkit-agent-tde, tdebluez, tdesshaskpass, tdeio-appinfo, tdepacman, kompose, mathemagics, twin-style-machbuntr14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-apps/tdepacman')
-rw-r--r--trinity-apps/tdepacman/Manifest1
-rw-r--r--trinity-apps/tdepacman/metadata.xml8
-rw-r--r--trinity-apps/tdepacman/tdepacman-14.1.0.ebuild31
-rw-r--r--trinity-apps/tdepacman/tdepacman-9999.ebuild31
4 files changed, 71 insertions, 0 deletions
diff --git a/trinity-apps/tdepacman/Manifest b/trinity-apps/tdepacman/Manifest
new file mode 100644
index 00000000..7bd5dbaf
--- /dev/null
+++ b/trinity-apps/tdepacman/Manifest
@@ -0,0 +1 @@
+DIST tdepacman-trinity-14.1.0.tar.xz 109488 BLAKE2B 1198aec2d20b52ffddcb488587d0bdabe1273d6a76dc8a22a9573432d94bdfe0b78ffe7d7bda739f91a0b74035c8f8fdbbc89ec15bc7a3a670ebfc764419d77b SHA512 20ec80e10a38a94bf65fc859e8b89141ece5e494a08f78d62fa59c601a8ee2b81b3a15aaa84844a01794bbb51750672ab1f29bbe2b05c4051a63bb1282895bc7
diff --git a/trinity-apps/tdepacman/metadata.xml b/trinity-apps/tdepacman/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-apps/tdepacman/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-apps/tdepacman/tdepacman-14.1.0.ebuild b/trinity-apps/tdepacman/tdepacman-14.1.0.ebuild
new file mode 100644
index 00000000..1d903e2d
--- /dev/null
+++ b/trinity-apps/tdepacman/tdepacman-14.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de es he pt sv"
+TRINITY_MODULE_TYPE="applications/games"
+inherit trinity-base-2
+
+DESCRIPTION="A pacman game for the Trinity Desktop"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~trinity-base/libtdegames-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/tdepacman/tdepacman-9999.ebuild b/trinity-apps/tdepacman/tdepacman-9999.ebuild
new file mode 100644
index 00000000..3e167f47
--- /dev/null
+++ b/trinity-apps/tdepacman/tdepacman-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de es he pt sv"
+TRINITY_MODULE_TYPE="applications/games"
+inherit trinity-base-2
+
+DESCRIPTION="A pacman game for the Trinity Desktop"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="~trinity-base/libtdegames-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}