summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdesvn/tdesvn-9999.ebuild
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-03-29 15:12:50 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-03-30 12:05:58 +0000
commit8a58e579fba7cebfce3d1170aa5fd3490013e5a1 (patch)
treef2eb744ac2507a2b5be2d06367001daa6eec407f /trinity-apps/tdesvn/tdesvn-9999.ebuild
parentf07444e61bbe03ef9a3e8c2050cc2d66cf2ff2bb (diff)
downloadtde-packaging-gentoo-8a58e579fba7cebfce3d1170aa5fd3490013e5a1.tar.gz
tde-packaging-gentoo-8a58e579fba7cebfce3d1170aa5fd3490013e5a1.zip
Live ebuilds: Add preliminary `TDESVN` ebuild.
Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-apps/tdesvn/tdesvn-9999.ebuild')
-rw-r--r--trinity-apps/tdesvn/tdesvn-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/trinity-apps/tdesvn/tdesvn-9999.ebuild b/trinity-apps/tdesvn/tdesvn-9999.ebuild
new file mode 100644
index 00000000..0a531569
--- /dev/null
+++ b/trinity-apps/tdesvn/tdesvn-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ca cs de es fr gl it ja lt nl pa ru sv"
+
+inherit trinity-base-2
+
+DESCRIPTION="Subversion client with tight TDE integration"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+IUSE+=" test"
+
+DEPEND+=" dev-vcs/subversion"
+RDEPEND+=" ${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TESTS="$(usex test)"
+ )
+
+ trinity-base-2_src_configure
+}