summaryrefslogtreecommitdiffstats
path: root/trinity-apps/tdesvn
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-10-27 13:50:17 +0300
committerSlávek Banko <slavek.banko@axis.cz>2023-10-29 10:05:05 +0100
commit271fc0de62480ffa8a1525e07b833079c96ca6bd (patch)
treefe24a566266198330ff71db390413fdf7a9d63af /trinity-apps/tdesvn
parent8e955e3a507fd32d4b98df0893bb2dfa83b48eb8 (diff)
downloadtde-packaging-gentoo-271fc0de62480ffa8a1525e07b833079c96ca6bd.tar.gz
tde-packaging-gentoo-271fc0de62480ffa8a1525e07b833079c96ca6bd.zip
Release R14.1.1 added
Signed-off-by: ormorph <roma251078@mail.ru> (cherry picked from commit 18d39ed9f062321b596258a9137f10b3e93b71e0)
Diffstat (limited to 'trinity-apps/tdesvn')
-rw-r--r--trinity-apps/tdesvn/Manifest1
-rw-r--r--trinity-apps/tdesvn/tdesvn-14.1.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/trinity-apps/tdesvn/Manifest b/trinity-apps/tdesvn/Manifest
index c6255cba..a33e2bb2 100644
--- a/trinity-apps/tdesvn/Manifest
+++ b/trinity-apps/tdesvn/Manifest
@@ -1 +1,2 @@
DIST tdesvn-trinity-14.1.0.tar.xz 1159688 BLAKE2B 6a58817353d10928f97646fb4d5ff9c588fe9a64558adf23fcdef0867fc34744a6f9000f8d64b3a991fb734edf6e70952f0e8a34146aec39b087b320ced9c868 SHA512 dbfd0766b96f4067bde3401cb19a69e0107d69a6b64ac51c8c9578dcd31e49e3feaf7518c686a522c4c7e62e42d65d85eddb4729349ade2f61e08599771fd009
+DIST tdesvn-trinity-14.1.1.tar.xz 1160424 BLAKE2B e4a28a3e856869a9a01bf9cbf51a9e016c7a2b1f4f0bee10a29f23e47c2eb41a0210419aea5deabb7d1aacab742bbabea3a82d8b076c8312893c21817914c78a SHA512 59db1318907179135622065f437aba5e202657ff1a2f315872d2d84e5d96c2f452655c8073ae5c36e68877b5a5905dccb35b6ceebab9ab15df940b73917c9e1c
diff --git a/trinity-apps/tdesvn/tdesvn-14.1.1.ebuild b/trinity-apps/tdesvn/tdesvn-14.1.1.ebuild
new file mode 100644
index 00000000..eaace786
--- /dev/null
+++ b/trinity-apps/tdesvn/tdesvn-14.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="ca cs de es fr gl it ja lt nl pa ru sv"
+TRINITY_MODULE_TYPE="applications/development"
+inherit trinity-base-2
+
+DESCRIPTION="Subversion client with tight TDE integration"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="test"
+
+RESTRICT+=" !test? ( test )"
+
+DEPEND="dev-vcs/subversion"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS="$(usex test)"
+ )
+ trinity-base-2_src_configure
+}