summaryrefslogtreecommitdiffstats
path: root/trinity-apps
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-04-01 04:11:30 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-04-01 13:02:44 +0000
commit90ee7645cc41c5fe89097dc700120ef57668fba2 (patch)
treee228912c4acf2873f8ff6135f1c427fb8c4b582a /trinity-apps
parent4aebf1a74ef218f2d6ade83aeeb6a0c6831add70 (diff)
downloadtde-packaging-gentoo-90ee7645cc41c5fe89097dc700120ef57668fba2.tar.gz
tde-packaging-gentoo-90ee7645cc41c5fe89097dc700120ef57668fba2.zip
Live ebuilds: Add preliminary `KPicoSim` ebuild.
Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'trinity-apps')
-rw-r--r--trinity-apps/kpicosim/kpicosim-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/trinity-apps/kpicosim/kpicosim-9999.ebuild b/trinity-apps/kpicosim/kpicosim-9999.ebuild
new file mode 100644
index 00000000..26027e27
--- /dev/null
+++ b/trinity-apps/kpicosim/kpicosim-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_TYPE="applications"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de"
+
+inherit trinity-base-2
+
+DESCRIPTION="IDE and simulator for the Xilinx PicoBlaze-3"
+HOMEPAGE="http://trinitydesktop.org/"
+LICENSE="|| ( GPL-2 GPL-3 )"
+
+need-trinity
+
+SLOT="${TRINITY_VER}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+
+ trinity-base-2_src_configure
+}