summaryrefslogtreecommitdiffstats
path: root/trinity-base/kcheckpass/kcheckpass-14.1.0.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-06-25 07:06:52 +0300
committerSlávek Banko <slavek.banko@axis.cz>2023-07-05 18:30:13 +0200
commite1526ec5deacd23d4c780f82459b85d73c5e3e9e (patch)
tree16fd951f417e45f73d4a68194101c93239e91c0a /trinity-base/kcheckpass/kcheckpass-14.1.0.ebuild
parentfe1c01c2898978a5e5a5dfd328b4a770cfd01119 (diff)
downloadtde-packaging-gentoo-e1526ec5deacd23d4c780f82459b85d73c5e3e9e.tar.gz
tde-packaging-gentoo-e1526ec5deacd23d4c780f82459b85d73c5e3e9e.zip
Adding patches for ksysguard, kcheckpass and tdm for stable ebuilds, fix issue #299
This resolves FTBFS - see issue TDE/tde-packaging-gentoo#299. Adds detection and optionally a prototype for strlcat and strlcpy for ksysguard and kcheckpass. It also adds an include <sys/ioctl.h> for the ioctl() prototype in tdm. The absence of these prototypes results in a build error with some compilers. Signed-off-by: ormorph <roma251078@mail.ru> (cherry picked from commit c704aa006b666ca063b57756e9111f238f5a21fa)
Diffstat (limited to 'trinity-base/kcheckpass/kcheckpass-14.1.0.ebuild')
-rw-r--r--trinity-base/kcheckpass/kcheckpass-14.1.0.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/trinity-base/kcheckpass/kcheckpass-14.1.0.ebuild b/trinity-base/kcheckpass/kcheckpass-14.1.0.ebuild
index 314c95bb..5dc52356 100644
--- a/trinity-base/kcheckpass/kcheckpass-14.1.0.ebuild
+++ b/trinity-base/kcheckpass/kcheckpass-14.1.0.ebuild
@@ -17,6 +17,11 @@ IUSE="pam"
RDEPEND="pam? ( trinity-base/tdebase-pam )"
DEPEND="${RDEPEND}"
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-strlcpy-${PV}.patch"
+ trinity-meta-2_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DWITH_SHADOW=ON