summaryrefslogtreecommitdiffstats
path: root/trinity-base/kcheckpass/kcheckpass-3.5.13.1.ebuild
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
commit644110a847c5911c2eb04eb53c93031740561efc (patch)
tree9658dde1cc70b52b233957b7852f87d997e98156 /trinity-base/kcheckpass/kcheckpass-3.5.13.1.ebuild
downloadtde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.tar.gz
tde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.zip
Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'trinity-base/kcheckpass/kcheckpass-3.5.13.1.ebuild')
-rw-r--r--trinity-base/kcheckpass/kcheckpass-3.5.13.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/trinity-base/kcheckpass/kcheckpass-3.5.13.1.ebuild b/trinity-base/kcheckpass/kcheckpass-3.5.13.1.ebuild
new file mode 100644
index 00000000..ccae69c9
--- /dev/null
+++ b/trinity-base/kcheckpass/kcheckpass-3.5.13.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdebase"
+
+inherit trinity-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="x86 amd64"
+IUSE="pam"
+
+RDEPEND="
+ pam? ( trinity-base/tdebase-pam )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -D_WITH_SHADOW=ON
+ $(cmake-utils_use_with pam PAM)
+ )
+
+ trinity-meta_src_configure
+}