summaryrefslogtreecommitdiffstats
path: root/trinity-base/kcontrol/kcontrol-14.1.2.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-28 17:23:47 +0300
committerSlávek Banko <slavek.banko@axis.cz>2024-04-29 00:52:31 +0200
commit94ec1d06986a97431ffc44951e92b075da19b93b (patch)
treed4601e9c08f8d576a5ce043fba5f73020f0c862d /trinity-base/kcontrol/kcontrol-14.1.2.ebuild
parent08657933720cc4345cdf62e1d42f199d8225e458 (diff)
downloadtde-packaging-gentoo-94ec1d06986a97431ffc44951e92b075da19b93b.tar.gz
tde-packaging-gentoo-94ec1d06986a97431ffc44951e92b075da19b93b.zip
Add new TDE-14.1.2
Signed-off-by: ormorph <roma251078@mail.ru> (cherry picked from commit 30335515923be5f5ee02981121d2cdb6ad89978d)
Diffstat (limited to 'trinity-base/kcontrol/kcontrol-14.1.2.ebuild')
-rw-r--r--trinity-base/kcontrol/kcontrol-14.1.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/trinity-base/kcontrol/kcontrol-14.1.2.ebuild b/trinity-base/kcontrol/kcontrol-14.1.2.ebuild
new file mode 100644
index 00000000..ae4cdcbf
--- /dev/null
+++ b/trinity-base/kcontrol/kcontrol-14.1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_TYPE="core"
+TSM_EXTRACT_ALSO="kicker/ twin/ kdesktop/ klipper/ kxkb/"
+inherit trinity-meta-2
+
+DESCRIPTION="The Trinity Control Center"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+IUSE="+hwlib ieee1394 logitech-mouse samba +svg +xrandr"
+
+DEPEND="
+ ~trinity-base/kicker-${PV}
+ ~trinity-base/libkonq-${PV}
+ ~trinity-base/tdelibs-${PV}[xrandr?]
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXrender
+ ieee1394? ( sys-libs/libraw1394 )
+ logitech-mouse? ( virtual/libusb:0 )
+ samba? ( net-fs/samba )
+"
+RDEPEND="${DEPEND}
+ sys-apps/usbutils
+ ~trinity-base/kcminit-${PV}
+ ~trinity-base/khelpcenter-${PV}
+ ~trinity-base/khotkeys-${PV}
+ ~trinity-base/tdebase-data-${PV}
+ ~trinity-base/tdesu-${PV}
+ svg? ( media-libs/libart_lgpl )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_XCURSOR=ON
+ -DWITH_XRENDER=ON
+ -DWITH_USBIDS=/usr/share/misc/usb.ids
+ -DWITH_SAMBA="$(usex samba)"
+ -DWITH_LIBUSB="$(usex logitech-mouse)"
+ -DWITH_LIBRAW1394="$(usex ieee1394)"
+ -DWITH_XRANDR="$(usex xrandr)"
+ -DWITH_TDEHWLIB="$(usex hwlib)"
+ -DWITH_LIBART="$(usex svg)"
+ -DXSCREENSAVER_DIR="/usr/$(get_libdir)/misc/xscreensaver"
+ )
+
+ trinity-meta-2_src_configure
+}