summaryrefslogtreecommitdiffstats
path: root/trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
commit644110a847c5911c2eb04eb53c93031740561efc (patch)
tree9658dde1cc70b52b233957b7852f87d997e98156 /trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild
downloadtde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.tar.gz
tde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.zip
Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild')
-rw-r--r--trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild b/trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild
new file mode 100644
index 00000000..2a7c868f
--- /dev/null
+++ b/trinity-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.13.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdegraphics"
+
+inherit trinity-meta
+
+DESCRIPTION="kfile plugins from kdegraphics"
+KEYWORDS="x86 amd64"
+IUSE="tiff openexr pdf"
+
+DEPEND="
+ tiff? ( media-libs/tiff:= )
+ openexr? ( >=media-libs/openexr-1.2.2-r2 )
+ pdf? ( app-text/poppler )"
+RDEPEND="$DEPEND"
+
+PATCHES=( "$FILESDIR/tdegraphics-poppler-tqt-remove-unnecessary-check.patch" )
+TSM_EXTRACT_ALSO="kghostview/dscparse/"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with tiff TIFF)
+ $(cmake-utils_use_with openexr OPENEXR)
+ $(cmake-utils_use_with pdf PDF)
+ )
+
+ trinity-meta_src_configure
+}