summaryrefslogtreecommitdiffstats
path: root/trinity-base/kdesktop/kdesktop-14.1.0.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2023-04-22 11:30:51 +0300
committerormorph <roma251078@mail.ru>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /trinity-base/kdesktop/kdesktop-14.1.0.ebuild
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/kdesktop/kdesktop-14.1.0.ebuild')
-rw-r--r--trinity-base/kdesktop/kdesktop-14.1.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/trinity-base/kdesktop/kdesktop-14.1.0.ebuild b/trinity-base/kdesktop/kdesktop-14.1.0.ebuild
new file mode 100644
index 00000000..a234cc7f
--- /dev/null
+++ b/trinity-base/kdesktop/kdesktop-14.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_TYPE="core"
+TSM_EXTRACT_ALSO="kcheckpass/ translations/ FindXscreensaver.cmake"
+inherit trinity-meta-2
+
+DESCRIPTION="The part of TDE UI that handles icons, desktop, screensaver etc"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="pam xscreensaver hwlib"
+
+COMMON_DEPEND="
+ ~dev-libs/dbus-1-tqt-${PV}
+ ~trinity-base/kcontrol-${PV}
+ ~trinity-base/libkonq-${PV}
+ x11-libs/libXrender
+ x11-libs/libXcursor
+ xscreensaver? ( x11-libs/libXScrnSaver )"
+ # Requires the desktop background settings module,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+DEPEND="${COMMON_DEPEND}
+ xscreensaver? ( x11-base/xorg-proto x11-misc/xscreensaver )"
+RDEPEND="${COMMON_DEPEND}
+ ~trinity-base/kcheckpass-${PV}
+ ~trinity-base/kdialog-${PV}
+ ~trinity-base/konqueror-${PV}
+ pam? ( trinity-base/tdebase-pam )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_XCURSOR=ON
+ -DWITH_XRENDER=ON
+ -DWITH_PAM="$(usex pam)"
+ -DWITH_XSCREENSAVER="$(usex xscreensaver)"
+ -DTDESCREENSAVER_PAM_SERVICE=tde
+ -DWITH_TDEHWLIB="$(usex hwlib)"
+ )
+ trinity-meta-2_src_configure
+}