summaryrefslogtreecommitdiffstats
path: root/trinity-base/kdesu/kdesu-3.5.13.1.ebuild
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-28 02:34:44 +0100
commit644110a847c5911c2eb04eb53c93031740561efc (patch)
tree9658dde1cc70b52b233957b7852f87d997e98156 /trinity-base/kdesu/kdesu-3.5.13.1.ebuild
downloadtde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.tar.gz
tde-packaging-gentoo-644110a847c5911c2eb04eb53c93031740561efc.zip
Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'trinity-base/kdesu/kdesu-3.5.13.1.ebuild')
-rw-r--r--trinity-base/kdesu/kdesu-3.5.13.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/trinity-base/kdesu/kdesu-3.5.13.1.ebuild b/trinity-base/kdesu/kdesu-3.5.13.1.ebuild
new file mode 100644
index 00000000..0f9802b2
--- /dev/null
+++ b/trinity-base/kdesu/kdesu-3.5.13.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdebase"
+
+inherit trinity-meta
+
+DESCRIPTION="Trinity gui for su(1) or sudo"
+KEYWORDS="x86 amd64"
+IUSE="sudo"
+
+DEPEND+=" sudo? ( app-admin/sudo )"
+RDEPEND+=" ${DEPEND}"
+
+src_configure () {
+ mycmakeargs=(
+ $(cmake-utils_use_with sudo SUDO_KDESU_BACKEND)
+ )
+
+ trinity-meta_src_configure
+}
+
+pkg_postinst () {
+ if use sudo; then
+ einfo "Remember sudo use flag sets only the defauld value"
+ einfo "It can be overriden on a user-level by adding:"
+ einfo " [super-user-command]"
+ einfo " super-user-command=su"
+ einfo "To the kdeglobal config file which is should be usually"
+ einfo "located in the ~/.trinity/share/config/ directory."
+ fi
+}