summaryrefslogtreecommitdiffstats
path: root/trinity-base/kicker/kicker-14.0.13.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-10-28 12:41:56 +0200
committerormorph <roma251078@mail.ru>2022-10-28 19:43:12 +0200
commit345c52699ff344a3bd46c0ee5df765dc404ac3d1 (patch)
tree752a6cb2512e0573cc46d7e89d3575a7a91840c6 /trinity-base/kicker/kicker-14.0.13.ebuild
parentcc26a6f102600556b4f96fd651ac2b67482e6932 (diff)
downloadtde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.tar.gz
tde-packaging-gentoo-345c52699ff344a3bd46c0ee5df765dc404ac3d1.zip
Added version 14.0.13
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/kicker/kicker-14.0.13.ebuild')
-rw-r--r--trinity-base/kicker/kicker-14.0.13.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/trinity-base/kicker/kicker-14.0.13.ebuild b/trinity-base/kicker/kicker-14.0.13.ebuild
new file mode 100644
index 00000000..c0cd7712
--- /dev/null
+++ b/trinity-base/kicker/kicker-14.0.13.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_TYPE="core"
+TSM_EXTRACT_ALSO="translations/"
+inherit trinity-meta-2
+
+DESCRIPTION="The Trinity application starter panel, capable of applets and extensions"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="xcomposite hwlib"
+
+DEPEND="~trinity-base/libkonq-${PV}
+ ~trinity-base/tdebase-data-${PV}
+ ~dev-libs/dbus-tqt-${PV}
+ xcomposite? ( x11-libs/libXrender
+ x11-libs/libXfixes
+ x11-libs/libXcomposite )"
+
+RDEPEND="${DEPEND}
+ ~trinity-base/kmenuedit-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_XFIXES="$(usex xcomposite)"
+ -DWITH_XRENDER="$(usex xcomposite)"
+ -DWITH_XCOMPOSITE="$(usex xcomposite)"
+ -DWITH_TDEHWLIB="$(usex hwlib)"
+ )
+
+ trinity-meta-2_src_configure
+}