summaryrefslogtreecommitdiffstats
path: root/trinity-base/kmail/kmail-14.0.12.ebuild
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2022-04-30 20:47:27 +0300
committerSlávek Banko <slavek.banko@axis.cz>2022-05-01 16:23:29 +0200
commit336d8ce82c00a00153a823a187dbc8e0bcf2c7a1 (patch)
tree920bb9b62e96c92b2a5a7e99352e68afb2783ce8 /trinity-base/kmail/kmail-14.0.12.ebuild
parent1c8d53512742aab368c0f7e9973604eaa54b43ba (diff)
downloadtde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.tar.gz
tde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.zip
Added version 14.0.12
Signed-off-by: ormorph <roma251078@mail.ru>
Diffstat (limited to 'trinity-base/kmail/kmail-14.0.12.ebuild')
-rw-r--r--trinity-base/kmail/kmail-14.0.12.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/trinity-base/kmail/kmail-14.0.12.ebuild b/trinity-base/kmail/kmail-14.0.12.ebuild
new file mode 100644
index 00000000..b75f3da5
--- /dev/null
+++ b/trinity-base/kmail/kmail-14.0.12.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdepim"
+TRINITY_MODULE_TYPE="core"
+TSM_EXTRACT_ALSO="
+ ktnef/
+ libemailfunctions/
+ mimelib/
+ libtdenetwork/
+ certmanager/lib/
+ libtdepim/
+ korganizer/kcalendariface.h
+ korganizer/korganizeriface.h
+ libkpimidentities/
+ libkpgp/
+ libkmime/
+ libksieve/
+ kmail/
+ translations/"
+inherit trinity-meta-2
+
+DESCRIPTION="The email client for Trinity"
+
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="crypt imap mbox sasl"
+
+# The magic of KMail, is fully done by individual TDEIOSlaves,
+# so we trigger them to be build, depending on USE flags.
+
+DEPEND="
+ ~trinity-base/certmanager-${PV}
+ ~trinity-base/ktnef-${PV}
+ ~trinity-base/libkcal-${PV}
+ ~trinity-base/libkmime-${PV}
+ ~trinity-base/libkpgp-${PV}
+ ~trinity-base/libkpimidentities-${PV}
+ ~trinity-base/libksieve-${PV}
+ ~trinity-base/libtdenetwork-${PV}
+ ~trinity-base/libtdepim-${PV}
+ ~trinity-base/mimelib-${PV}
+"
+RDEPEND="${DEPEND}
+ ~trinity-base/tdebase-tdeioslaves-${PV}
+ crypt? ( app-crypt/pinentry )
+ imap? ( ~trinity-base/tdepim-tdeioslaves-${PV}[sasl=] )
+ mbox? ( ~trinity-base/tdepim-tdeioslaves-${PV} )
+ sasl? ( ~trinity-base/tdebase-tdeioslaves-${PV}[sasl=] )
+"
+
+src_install() {
+ trinity-meta-2_src_install
+ insinto "${TDEDIR}/include/kmail"
+ doins "${BUILD_DIR}/kmail"/*.h
+}
+
+pkg_postinst () {
+ if use crypt; then
+ elog "Remember that you can build Pinentry with TQt support."
+ elog "To do so, just emerge app-crypt/pinentry with \"tqt\" USE"
+ elog "and use \"eselect pinentry set pinentry-tqt\" to use it."
+ fi
+}